Page MenuHomePhabricator

If loading a preset search in the URL, the page is non dynamic
Closed, ResolvedPublic

Description

I noticed this when using my browser's autocomplete to load the media search URL. It autocompleted to a link that included the q=searchterm parameter. The page loaded with image results — but the entire page was non responsive, as if the Javascript didn't load properly. Clicking images loaded their page in Commons, and it wasn't possible to click into the search input box.

Steps to reproduce:

  1. Click on a link to Special:MediaSearch that already has a query. Example: https://commons.wikimedia.org/wiki/Special:MediaSearch?type=bitmap&q=puppy
  2. Let the page load
  3. Try to interact with the search input, or any of the search results

Expected: Same dynamic behavior (overlay popup / change of search terms) as when the page loads without an initial search.

Actual behavior: The input is non-responsive, no overlay popup (clicking on a result sends the browser to the page in commons)

I didn't see any errors in the console.

Event Timeline

Mooeypoo created this task.Sun, Jan 3, 2:03 AM
Restricted Application added a project: Structured-Data-Backlog. · View Herald TranscriptSun, Jan 3, 2:03 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Mooeypoo updated the task description. (Show Details)Sun, Jan 3, 2:04 AM
Mooeypoo added a comment.EditedThu, Jan 7, 12:46 AM

I am not sure if you've done anything in the past couple of days, but I haven't encountered this issue anymore.

I kinda feel gaslighted by my own browser. I swear, this was a real bug! ... but it seems to be working perfectly now.

I guess this is going to be a quick estimation session for the team. Keep up the great work, this search is <chef kiss>

CBogen added a subscriber: CBogen.Thu, Jan 7, 2:59 PM

@Mooeypoo I saw the bug too when you first reported it! But I'm also not seeing it anymore. I'll leave the ticket open for another couple of days to see if it reappears.

Etonkovidova closed this task as Resolved.Thu, Jan 14, 1:55 AM
Etonkovidova claimed this task.
Etonkovidova added a subscriber: Etonkovidova.

Tested in commons wmf.26 (the current production) with network thrilling and disabled cache.
Most likely the issue can be observed with "cold cache"?
The page while being loaded is sufficiently interactive but the interactivity has its limitations - the filters are not loaded and thus cannot be interacted with.
When the page loads a user can

  • type/change the search terms
  • change the tab filters

The loading experience can be smoother and there is a task for it - https://phabricator.wikimedia.org/T271874.

I'm closing this as Resolved, but I'll do some monitoring/testing for possible loading issues.