Page MenuHomePhabricator

Templates are not appearing in categories
Closed, InvalidPublic

Assigned To
None
Authored By
Bebiezaza
Jan 3 2021, 5:52 PM
Tags
None
Referenced Files
F33983797: image.png
Jan 3 2021, 6:41 PM
F33983786: Screenshot 2021-01-03 at 18.33.40.png
Jan 3 2021, 6:34 PM
F33983784: Screenshot 2021-01-03 at 18.33.23.png
Jan 3 2021, 6:34 PM
F33983785: Screenshot 2021-01-03 at 18.33.34.png
Jan 3 2021, 6:34 PM

Description

Steps to Reproduce:

  1. Go to https://th.wikipedia.org
  2. Go to any templates, in this case: https://th.wikipedia.org/wiki/แม่แบบ:กล่องข้อมูล_สถานีอวกาศ
  3. Edit the documentation and insert categories, in this case: https://th.wikipedia.org/wiki/หมวดหมู่:แม่แบบการบินอวกาศ
  4. Save the documentation

Actual Results: Templates are not appearing in categories.
Expected Results: Templates would appear in categories.

This bug is on many templates, including the example, https://th.wikipedia.org/wiki/แม่แบบ:กล่องข้อมูล ท่าอากาศยาน (in this case I put the category directly on the template, which I shouldn't) and https://th.wikipedia.org/wiki/แม่แบบ:กล่องข้อมูล หอดูดาว

Event Timeline

Are you just being impatient?

Screenshot 2021-01-03 at 18.33.40.png (914×1 px, 193 KB)

Screenshot 2021-01-03 at 18.33.34.png (690×1 px, 103 KB)

Screenshot 2021-01-03 at 18.33.23.png (1×1 px, 234 KB)

actually, [[แม่แบบ:กล่องข้อมูล ท่าอากาศยาน]] is already working, but I have done it through the unrecommended technique and not putting the category in the documentation.

image.png (851×1 px, 209 KB)

For [[แม่แบบ:กล่องข้อมูล สถานีอวกาศ]] and [[แม่แบบ:กล่องข้อมูล หอดูดาว]], they have been broken since 31st of december, 2020. Which is the day I moved the template to the current category.

I might be impatient too because the other four templates are showing in the category perfectly fine right after I moved the template to the current category, but it shouldn't be taking this long to appear.

When it next happens, can you see if null editing and/or purging helps?

When it next happens, can you see if null editing and/or purging helps?

I already purged [[แม่แบบ:กล่องข้อมูล สถานีอวกาศ]] and [[แม่แบบ:กล่องข้อมูล หอดูดาว]], including [[หมวดหมู่:แม่แบบการบินอวกาศ]], a bunch of times already and nothing improves.

If this what you meant by null editing, I already

  1. edit and save them again without editing.
  2. minor edits, like changing from [[หมวดหมู่:แม่แบบการบินอวกาศ|สถานีอวกาศ]] to [[หมวดหมู่:แม่แบบการบินอวกาศ|ส]].
Bebiezaza closed this task as Invalid.EditedJan 6 2021, 3:54 PM

I experimented with multiple templates and concluded I need to do an edit (even if it's one character) to the main template page so that templates will appear in categories.