Page MenuHomePhabricator

Convert SecurePoll VoterEligibilityPage to use OOUI
Closed, ResolvedPublic

Description

Use OOUI for the form on VoterEligibilityPage.php

Event Timeline

Change 654328 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[mediawiki/extensions/SecurePoll@master] Use OOUI for VotereligibilityPage form

https://gerrit.wikimedia.org/r/654328

Change 654328 merged by jenkins-bot:
[mediawiki/extensions/SecurePoll@master] Use OOUI for VoterEligibilityPage form

https://gerrit.wikimedia.org/r/654328

dom_walden added a subscriber: dom_walden.

I can successfully submit the votereligibility form on Chromium 83 and Safari 12. I used all the inputs on the form and checked that the correct data was saved.

The votereligibility form was also tested on other browser as part of T271834.

Test Environment: Patch Demo MediaWiki 1.36.0-alpha (2f433de), SecurePoll 2.0.0 (02a680d) 11:14, 21 January 2021.