Page MenuHomePhabricator

add title and/or pageid to action=parse output
Closed, ResolvedPublic

Description

Please add the pageid and/or the title to the parse output.

Thanks.


Version: unspecified
Severity: enhancement

Details

Reference
bz25134
Related Gerrit Patches:
mediawiki/core : masterAdd pageid to API parse output

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 21 2014, 11:16 PM
bzimport added a project: MediaWiki-API.
bzimport set Reference to bz25134.
bzimport added a subscriber: Unknown Object (MLST).

Maybe all attributs like prop=info? The module cannot used as generator, so this can save a second query.

At least pageid/ns/title/revid/redirect. Thanks.

Bryan.TongMinh wrote:

(In reply to comment #1)

Maybe all attributs like prop=info? The module cannot used as generator, so
this can save a second query.

I think it should be able to be used as generator.

You can't use an action= module as a generator, that's impossible by design.

It sounds like parse should really be an action=query submodule rather than a separate module. Worth thinking about, I guess.

Bryan.TongMinh wrote:

(In reply to comment #3)

You can't use an action= module as a generator, that's impossible by design.
It sounds like parse should really be an action=query submodule rather than a
separate module. Worth thinking about, I guess.

Or allow ApiQuery to operate on the ApiParse result. That would require several work on the query modules though.

njh wrote:

I would really appreciate being able to get the data returned by action=query&prop=info.

It isn't currently possible to get the last modified/touched date from a action=parse (even through screen scraping) and it seems wasteful to do a second request to get it.

*** Bug 28814 has been marked as a duplicate of this bug. ***

Anomie moved this task from Unsorted to Needs Code on the MediaWiki-API board.Feb 20 2015, 7:23 PM
Sn1per claimed this task.Jul 17 2015, 3:27 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 17 2015, 3:27 AM

Would it be a good idea to make parse into an action=query module? It could break a lot of things.

Anomie added a subscriber: Anomie.Jul 28 2015, 5:11 PM

Current status here is that we already have 'title', and adding 'pageid' wouldn't be terribly difficult.

Making a parse query module is an interesting idea, but has some things to consider. Presumably it would be a list module, with the ability to say which of the various page lists should be output in generator mode? Is that really a major advantage over an action=parse call then using pageids or titles, especially when continuation of any of the prop modules would mean a re-parse?

prop=revisions already allows to parse from an action=query, there is no need for a new parse module

action=parse is just needed, when parsing your own wikitext. To parse already existing version(s) it is easier to use prop=revisions, but action=parse also allow this with pageid or oldid. prop=revisions also allows to combine multiple web requests to action=query into one.

Ah, OK. Was just reading through the older comments and wasn't sure if the old suggestions were still relevant, thanks.

Change 227764 had a related patch set uploaded (by Sn1per):
Add pageid to API parse output

https://gerrit.wikimedia.org/r/227764

Change 227764 merged by jenkins-bot:
Add pageid to API parse output

https://gerrit.wikimedia.org/r/227764

Sn1per closed this task as Resolved.Jul 30 2015, 6:46 PM

hooray! :D