With the new hook system, extensions define their own HookRunners. Thus, it would be useful to allow using HookRunnerTest for extension runners.
I think a possibility would be to have the current HookRunnerTest become an abstract class (it should also be renamed), with provideHookRunners as abstract method. Extensions would extend this class and return the names of their hook runners. Core would do the same, like HookRunnerTest::provideHookRunners currently does.