Page MenuHomePhabricator

Wikipedia pages need more work to properly go BACK in Chrome browser
Closed, DeclinedPublic

Description

There you have it. The official statement from the Chrome (world's most used) Browser team,

I believe pages like this need to do some work

They are saying that Wikipedia pages need more work to properly go BACK in Chrome browser .

As to the exact amount of pages, and what work needs to be done. That is all over my head.

I am just relaying their official statement which you should please read for the details. Thanks.

Event Timeline

Jidanni created this task.Jan 11 2021, 11:11 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 11 2021, 11:11 PM
Jidanni updated the task description. (Show Details)Jan 11 2021, 11:12 PM
Jidanni updated the task description. (Show Details)
Jidanni updated the task description. (Show Details)Jan 11 2021, 11:15 PM
Aklapper changed the task status from Open to Stalled.Jan 12 2021, 7:59 AM

@Jidanni: As requested before, please do follow the scheme on https://www.mediawiki.org/wiki/How_to_report_a_bug when creating tickets here. Wikimedia Phabricator is not some forum to drop drive-by comments... If it is somehow not possible to create helpful and actionable bug reports with sufficient information, then I'd suggest that you may want to spend your time somewhere else. Thanks for your understanding.

In different words: "Someone please read something on some other website" is not a bug report. :) Please bring up and discuss such things first in (technical) venues (https://meta.wikimedia.org/wiki/Tech, mailing lists, IRC, etc) to sort out actionable parts and get potential items in shape for https://www.mediawiki.org/wiki/How_to_report_a_bug . Thanks a lot.

This one is too hard. OK I'll close it.

Jidanni closed this task as Declined.Jan 12 2021, 8:10 AM
Aklapper added a comment.EditedJan 12 2021, 8:15 AM

There is a good structured bug report in the initial comment at https://bugs.chromium.org/p/chromium/issues/detail?id=1038183#c0 in the format that is also expected here in Wikimedia Phabricator.
There is a comment in https://bugs.chromium.org/p/chromium/issues/detail?id=1038183#c8 which provides some basics what needs to be done.
Both could have been initially copied and pasted into this ticket in Wikimedia Phabricator. I don't understand why this was not done by the reporter, basically.

OK, if it turns out my bug has any merit, feel free to reopen it.

Please see previous comments.

Jidanni added a comment.EditedFri, Feb 5, 1:10 AM

"

  1. Visit https://en.m.wikipedia.org/wiki/List_of_phobias
  2. Scroll down to Frigophobia.
  3. Tap on it.
  4. Now tap your phone's back button.

What is the expected behavior?
We should be back in the F area.

What went wrong?
We are sent back to the A area and we have to scroll all the way back down to figure out where we were reading.

  1. Go to https://en.m.wikipedia.org/wiki/List_of_phobias
  2. Open developer options
  3. Click the "toggle device toolbar" button
  4. Force reload
  5. Scroll down to Frigophobia
  6. Click on it
  7. Hit back

I believe pages like this need to do some work to make restoration work correctly and use the history.scrollRestoration API: https://developer.mozilla.org/en-US/docs/Web/API/History/scrollRestoration

There isn't much we can do on the browser-side.
"

We are sent back to the A area and we have to scroll all the way back down to figure out where we were reading.

Not here when using https://en.m.wikipedia.org/wiki/List_of_phobias on desktop Chromium and its back button. (No phone here with "back buttons".)

and use the history.scrollRestoration API

That's for web applications instead.

Okay I just tried it with a cell phone and now the page is working properly.