Page MenuHomePhabricator

Special:RecentChanges failing to load due to running out of memory
Closed, ResolvedPublic

Description

Multiple hu.wikipedia users reported that their watchlist is not working (they are getting a white screen of death with an internal server error). The error seems to be specific to a handful of users, and they are getting it consistently every time as long as advanced recent changes are enabled.

Here is an example of such a request:
URL: http://hu.wikipedia.org/wiki/Speci%C3%A1lis:Friss_v%C3%A1ltoztat%C3%A1sok
Time: Sun, 12 Sep 2010 16:10:05 GMT
IP: 84.3.52.70
Status Code: 500 Internal Server Error


Version: unspecified
Severity: minor

Details

Reference
bz25190

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 11:20 PM
bzimport set Reference to bz25190.
bzimport added a subscriber: Unknown Object (MLST).
Tgr created this task.Sep 16 2010, 8:28 PM
Tgr added a comment.Sep 16 2010, 9:01 PM

Sorry, recent changes, not watchlist.

Seems to work now. I didn't see any relevant entries in the error log for Sep 12 16:10:nn GMT

bdamokos wrote:

I think the "works for me" is not an adequate resolution for an error that seems to affect a handful of users and not at all all the others.

E.g. It doesn't work for me (user:bdamokos) at all on the Hungarian Wikipedia - while it does work on the English with advanced recent changes turned on. I can reproduce the problem on all the browsers (Chrome, FF 3.6.3) and Operating systems (Ubuntu, Win XP, Win 7) that I have tested on.

demon added a comment.Sep 17 2010, 2:03 PM

Also works for me using Chrome.

Logged in, turned on enhanced RC, browsed to [[Speciális:Friss_változtatások]]. Didn't get any errors at all.

(In reply to comment #3)

I think the "works for me" is not an adequate resolution for an error that
seems to affect a handful of users and not at all all the others.

E.g. It doesn't work for me (user:bdamokos) at all on the Hungarian Wikipedia -
while it does work on the English with advanced recent changes turned on. I can
reproduce the problem on all the browsers (Chrome, FF 3.6.3) and Operating
systems (Ubuntu, Win XP, Win 7) that I have tested on.

Are you getting these blank pages still? Could you hit it again and tell me when you hit it so I can check the logs?

bdamokos wrote:

The problem still persist - it has persisted for some time.

Here is a recent request header with Chrome. (I get the same error with Internet Explorer but it doesn't have such a nice readout feature.)

Request URL:http://hu.wikipedia.org/wiki/Speci%C3%A1lis:Friss_v%C3%A1ltoztat%C3%A1sok
Request Method:GET
Status Code:500 Internal Server Error
Request Headers
Accept:application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Cache-Control:max-age=0
Referer:http://hu.wikipedia.org/wiki/Speci%C3%A1lis:Friss_v%C3%A1ltoztat%C3%A1sok
User-Agent:Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/534.3 (KHTML, like Gecko) Chrome/6.0.472.59 Safari/534.3
Response Headers
Cache-Control:private, s-maxage=0, max-age=0, must-revalidate
Connection:close
Content-Encoding:gzip
Content-Length:20
Content-Type:text/html
Date:Fri, 17 Sep 2010 14:22:43 GMT
Server:Apache
Vary:Accept-Encoding
X-Cache:MISS from sq72.wikimedia.org, MISS from amssq38.esams.wikimedia.org, MISS from amssq32.esams.wikimedia.org
X-Cache-Lookup:MISS from sq72.wikimedia.org:3128, MISS from amssq38.esams.wikimedia.org:3128, MISS from amssq32.esams.wikimedia.org:80

Tgr added a comment.Sep 19 2010, 9:37 PM

To clarify, the bug effects a handful of people only (I think 4 people have reported it on hu.wikipedia), but for them it is permanent (one of them said he has been unable to use advanced recent changes for the last 1.5 years ).

bdamokos wrote:

For the record the error still exists for me but now at least I get the Wikimedia Foundation error page.

The error is:
"PHP fatal error in /usr/local/apache/common-local/php-1.17/includes/ChangesList.php line 1152:
Allowed memory size of 83886080 bytes exhausted (tried to allocate 2763979 bytes) "

The settings for RC I have:
*number of days to show: 30;
*number of edits to show: 5000.
*Use the advanced RC thingy (requires Javascript): ticked.

I can reproduce that http://hu.wikipedia.org/w/index.php?title=Speciális:Friss_változtatások&limit=4000&days=30 (With or without enhanced rc) Does anyone still get the white screen, or does everyone get the new error described in the comment above (aka did wikimedia just change its error message, or is this a different error)

Bawolff, the new error message is the result of having enabled wmerrors.

demon removed a subscriber: demon.Mar 9 2017, 9:38 PM
Krinkle closed this task as Resolved.Oct 27 2018, 8:23 PM

Unable to reproduce. If this is still observed sometimes, please create a new task.

Restricted Application added a project: Growth-Team. · View Herald TranscriptOct 27 2018, 8:23 PM
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:12 PM