Page MenuHomePhabricator

Make wikihiero extension compatible with Parsoid
Closed, ResolvedPublic

Description

Parsoid has its own extension API - see https://www.mediawiki.org/wiki/Parsoid/Extension_API.
In this first phase, we are targeting tag-hook extensions for migration.
The wikihiero extension needs an update to work directly with Parsoid.

Event Timeline

Arlolra triaged this task as Medium priority.Feb 25 2021, 5:23 PM
Arlolra moved this task from Backlog to Missing Functionality on the Parsoid board.

Change 751751 had a related patch set uploaded (by Isabelle Hurbain-Palatin; author: Isabelle Hurbain-Palatin):

[mediawiki/extensions/wikihiero@master] Add explicit Parsoid support

https://gerrit.wikimedia.org/r/751751

Change 752164 had a related patch set uploaded (by Isabelle Hurbain-Palatin; author: Isabelle Hurbain-Palatin):

[integration/config@master] Add 'parsoid' to 'wikihiero' extension dependencies

https://gerrit.wikimedia.org/r/752164

Change 752164 merged by jenkins-bot:

[integration/config@master] Add 'parsoid' to 'wikihiero' extension dependencies

https://gerrit.wikimedia.org/r/752164

Change 751751 merged by jenkins-bot:

[mediawiki/extensions/wikihiero@master] Add explicit Parsoid support

https://gerrit.wikimedia.org/r/751751