Page MenuHomePhabricator

[wmf.28-regression] frwiktionary - SE module displayed on Homepage with errors
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

  1. Log in frwiktionary and enable Homepage in Special:Preferences.
  2. Go to Special:Homepage (click on a username in the personal toolbar)
  3. The SE intro tour will be displayed with some options disabled.

Actual Results:

The console will display

Cannot read property 'html' of undefined TypeError: Cannot read property 'html' of undefined
  at StartEditingDialog.setupSuggestedEditsModule
  1. Reload the page - the SE module will be gone.

Expected Results:
frwiktionary is not supposed to have SE module activated.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 28 2021, 11:02 PM
Restricted Application added a project: User-Urbanecm_WMF. · View Herald TranscriptMon, Feb 1, 6:34 PM

Change 660875 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/extensions/GrowthExperiments@master] SpecialHomepage: Do not load start-startediting if SE aren't enabled

https://gerrit.wikimedia.org/r/660875

Does anyone have a screenshot of frwiktionary homepage pre-regression?

After I make it not to render the onboarding module (start-startediting) via the patch above, it looks like this:

which...doesn't look like something we want.

Change 660928 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/extensions/GrowthExperiments@wmf/1.36.0-wmf.28] SpecialHomepage: Do not load start-startediting if SE aren't enabled

https://gerrit.wikimedia.org/r/660928

Does anyone have a screenshot of frwiktionary homepage pre-regression?

After I make it not to render the onboarding module (start-startediting) via the patch above, it looks like this:

which...doesn't look like something we want.

Kosta confirmed to me via IRC that this is correct. CR'ed by Kosta => will backport shortly.

Change 660928 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@wmf/1.36.0-wmf.28] SpecialHomepage: Do not load start-startediting if SE aren't enabled

https://gerrit.wikimedia.org/r/660928

Mentioned in SAL (#wikimedia-operations) [2021-02-01T19:41:49Z] <urbanecm@deploy1001> Synchronized php-1.36.0-wmf.28/extensions/GrowthExperiments/includes/Specials/SpecialHomepage.php: 1acaba4b3650dfb757d29af5395cc7660c839756: SpecialHomepage: Do not load start-startediting if SE arent enabled (T273243) (duration: 01m 05s)

Change 660875 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] SpecialHomepage: Do not load start-startediting if SE aren't enabled

https://gerrit.wikimedia.org/r/660875

Fix was deployed seconds ago.

Change 660937 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/extensions/GrowthExperiments@wmf/1.36.0-wmf.27] SpecialHomepage: Do not load start-startediting if SE aren't enabled

https://gerrit.wikimedia.org/r/660937

Change 660937 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@wmf/1.36.0-wmf.27] SpecialHomepage: Do not load start-startediting if SE aren't enabled

https://gerrit.wikimedia.org/r/660937

Mentioned in SAL (#wikimedia-operations) [2021-02-02T12:18:52Z] <urbanecm@deploy1001> Synchronized php-1.36.0-wmf.27/extensions/GrowthExperiments/includes/Specials/SpecialHomepage.php: 18c59d018b6ef72c750e25588518d2df6f492db3: SpecialHomepage: Do not load start-startediting if SE arent enabled (T273243) (duration: 01m 01s)

Etonkovidova closed this task as Resolved.Wed, Feb 3, 1:47 AM

Checked on frwiktionary wmf.27- works as expected now.