Page MenuHomePhabricator

Log entries and edit summaries should be separate messages
Closed, ResolvedPublic

Description

Author: theevilipaddress

Description:
Currently, messages like [[MediaWiki:Protectedarticle]] or [[MediaWiki:Modifiedarticleprotection]] (also [[MediaWiki:Unprotectedarticle]], [[MediaWiki:1movedto2]], [[MediaWiki:1movedto2 redir]] or [[MediaWiki:Overwroteimage]] from which I remember in core, probably several more in extensions) are used twice in the software: once as log entry, e.g. Some guy (talk | contribs) protected "Foo" (Edit warring [edit=sysop] (indefinite) [move=sysop] (indefinite)) or as summary in the revision history and the protecting admin's contributions: protected "Foo" (Edit warring [edit=sysop] (indefinite) [move=sysop] (indefinite))

However, I think that the edit summary should be different. It is a bit pointless to repeat the {{FULLPAGENAME}} in the summary, because that's clear already anyway if you look at some page's history or someone's contribs, where the article is linked. Thus, it should rather be "protected page (Edit warring [edit=sysop] (indefinite) [move=sysop] (indefinite)). Especially good would such a change be when we have a long {{FULLPAGENAME}}. On Commons, where some bots tend to make horribly long filenames, it already occured that when uploading a new file version or protecting it, there was nothing but "uploaded a new version of" or "protected" and some part of the {{FULLPAGENAME}} in it.

Furthermore (not in English probably) in some cases in German, different sentences could be used depending on the situation, because one time the shorter form is generally ok, but in the other case it would be wrong. This would also some some characters in such a case. Also, would be a partial fix of bug 16921.

I recognize that it may not be easy, I even personally looked where exactly these messages are used within the software, looking if I can come up with some ideas or even a patch, but I failed, so I wouldn't mind this lying around here some time, since it appears not to be a simple fix.


Version: unspecified
Severity: enhancement

Details

Reference
bz25351

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 11:20 PM
bzimport set Reference to bz25351.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Sep 28 2010, 6:02 PM
Meno25 removed a subscriber: Meno25.Feb 19 2016, 5:43 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 19 2016, 5:43 PM
Krinkle closed this task as Resolved.Feb 9 2019, 7:57 PM
Krinkle claimed this task.
Krinkle added a subscriber: Krinkle.

The edit summary and log action formatting are actually already separated. And individual features such as page move, and page protect already decide for themselves what to use where.

Also, in the current version of MediaWiki, it seems these two are actually different already, so I'm marking this as resolved. For example, when protecting a page, the edit summary of the fake revision is:

Protected "Main Page": example reason ([Edit=Allow only autoconfirmed users] (indefinite) [Move=Allow only autoconfirmed users] (indefinite)))

.. which comes from the interface messages protectedarticle-comment, modifiedarticleprotection-comment, and unprotectedarticle-comment.

The log entry is:

Admin (..) protected Main Page [Edit=Allow only autoconfirmed users] (indefinite) [Move=Allow only autoconfirmed users] (indefinite) (example reason)

.. which come from the interface message logentry-protect-protect, with variants for other protect actions and modes.