Page MenuHomePhabricator

Decide on naming conventions in MediaUploader
Closed, ResolvedPublic


MediaUploader is a fork of UploadWizard, but, rather obviously, has a different name. This introduces a few issues we'll have to deal with:

  • Special page name – rename Special:UploadWizard to Special:MediaUploader, add a b/c alias (T275273).
  • PHP class names – we will probably want to namespaceify the code anyway, so changing the names at the same time would probably be sane. There is also not that much PHP code anyway, so changing it all shouldn't be too hard.
  • Configuration variables – rename it, but maintain backwards compatibility. There is only one config variable.
  • Message keys – we should probably rename them to avoid conflicts with UW in the future. Should also register the extension with translatewiki when that is finished.
    • A migration script for renaming local message overrides would be useful. It would move any wikipage like MediaWiki:mwe-upwiz-* to their new names. On the other hand, these messages may have changed, so that may just introduce additional chaos.
  • JS class/method/variable/RL module names – they stay as they were for now. This will be changed during the Vue + ES6 refactoring. Will have to make it clear in the MVP release that these modules, classes, etc. will all change names later.
  • CSS class names – should follow the JS convention.
  • User rights and groups – keep the old names for b/c, no need to change them.
  • Namespace IDs – keep the old ID for Campaign: namespace.
  • User options – keep the old keys for b/c.
  • uw_campaigns table – can rename it easily, provide an update to do that. The table can also be regenerated.
    • Renamed to mu_campaign. See also T285236.


  • In order to prevent any conflicts, MediaUploader should not be able to be loaded alongside UploadWizard. This also has to be clearly stated in the docs.

Any comments are welcome.

Event Timeline

Ostrzyciel moved this task from To Triage to In Progress on the MediaUploader board.