Page MenuHomePhabricator

Reason dropdown field not displayed when protecting a page on French Wikipedia to users without interface-admin user right
Closed, InvalidPublic

Description

On frWP, the GUI for protecting a page has changed recently (today?), and now it's not possible anymore to add a textual reason for protecting the page.

PageProtectWithoutReason.png (828×1 px, 52 KB)

In my protection log, protection appear now with useless comments (infinite, othertime). Is it possible to add again the ability to explain why a sysop protects the page?

Talk on frWP.

Event Timeline

Thanks for reporting this. Wondering if this is related to T236218: ProtectionForm::buildForm is deprecated in favor of ProtectionForm::addFormFields.

Cannot reproduce on mediawiki.org, the Reason: and Other/additional reason: dropdowns are shown:

Screenshot from 2021-02-16 20-56-37.png (712×911 px, 54 KB)

Aklapper renamed this task from Unable to add a reason when protecting a page to Reason dropdown field not displayed when protecting a page on French Wikipedia.Feb 16 2021, 7:58 PM

Just to confirm I understand the issue, per @Aklapper I am also seeing the following - is this what is supposedly missing?:

Screen Shot 2021-02-16 at 12.20.58 PM.png (604×2 px, 78 KB)

If so, I'll explore what could be happening here..

@NicoV could you also confirm you do not see it on the following URL:
https://fr.wikipedia.org/w/index.php?title=VTV_1&action=protect&safemode=1
?

Just to confirm I understand the issue, per @Aklapper I am also seeing the following - is this what is supposedly missing?:

Screen Shot 2021-02-16 at 12.20.58 PM.png (604×2 px, 78 KB)

If so, I'll explore what could be happening here..

@NicoV could you also confirm you do not see it on the following URL:
https://fr.wikipedia.org/w/index.php?title=VTV_1&action=protect&safemode=1
?

This is indeed what is missing. But for the URL you gave, I can see it.
But on this one, I don't see it: https://fr.wikipedia.org/w/index.php?title=Gilbert_Moses&action=protect

Thanks @NicoV, that URL is helpful. I can replicate this now.. I wonder what's going on here...

Update: It seems related to user rights. I can see the reason box with my staff account.

Screen Shot 2021-02-16 at 12.57.36 PM.png (1×2 px, 344 KB)

but not with my volunteer account:

Screen Shot 2021-02-16 at 12.57.43 PM.png (1×1 px, 166 KB)

@NicoV can you confirm whether you have the "editinterface" user right?

Yes, NicoV should have editinterface thanks to being a sysop.

Yes, NicoV should have editinterface thanks to being a sysop.

@Aklapper explicitly I am asking if the checkbox "interface administrator" is ticked on https://fr.wikipedia.org/w/index.php?title=Sp%C3%A9cial%3APermissions&user=NicoV
If not, @NicoV please humor me and try ticking it to see if anything changes.

@NicoV can you also confirm that the protection form does not show on https://fr.wikipedia.org/w/index.php?title=Gilbert_Moses&action=protect&safemode=1 ?

Jdlrobson renamed this task from Reason dropdown field not displayed when protecting a page on French Wikipedia to Reason dropdown field not displayed when protecting a page on French Wikipedia to users without interface-admin user right.Feb 16 2021, 10:17 PM
Jdlrobson closed this task as Invalid.

According to https://fr.wikipedia.org/wiki/Sp%C3%A9cial:Journal?type=protect&user=&page=&wpdate=&tagfilter=&wpfilters%5B%5D=newusers, some users are still able to set a reason for protection, so this bug is definitely limited to certain users.

I managed to track this down to this on-wiki page: https://fr.wikipedia.org/wiki/MediaWiki:Group-sysop.css
It explicitly hides the reason box.

@Jdlrobson
Here's the current status :

About https://fr.wikipedia.org/wiki/MediaWiki:Group-sysop.css, it hasn't been modified since 2018, so there's probably something else going on.

@Jdlrobson

According to the comment on Group-sysop.css, it says that "it hides MediaWiki:Protect-cascade, which shouldn't be used". And indeed, when I check again https://fr.wikipedia.org/w/index.php?title=Gilbert_Moses&action=protect&safemode=1, the box title says "Protection en cascade - A NE PAS UTILISER" (Protect cascade - DO NOT USE). So what has changed about the usage of "Protect-cascade" ?

I just saw your message on frWP sysop board: feel free to close again, but I still believe there's something going on with Protect-cascade

Aklapper removed a project: Regression.

No problem @NicoV I'm just glad this got fixed and you are able to use it again. In case it wasn't clear the HTML changed and the existing CSS written in 2018 was a little over-zealous. You can always check if the issue is with Wikimedia deployed code or gadgets / site styles and scripts by adding safemode=1 to the end of any URL to see if the problem goes away (which explains why you could see the form in T274934#6835280).

@Jdlrobson
One remark made on frWP is that the identifier of the fields should be more descriptive and stable, so that CSS styling can be safely applied on some fields. Currently, it seems that the fields identifiers are auto-numbered so they can change with new versions or even for different usages of the page (depending on what other fields are added or not). Would it be possible to have meaningful identifiers for the fields, instead of things like ooui-php-18 currently in ProtectionForm for the checkbox for the cascade protection?

Would it be possible to have meaningful identifiers for the fields

Please file a new enhancement request for different topics. Thanks a lot!