Page MenuHomePhabricator

Drop PHP 7.3 support in MediaWiki when appropriate
Open, Stalled, Needs TriagePublic

Description

Follow-up to T257879: Drop PHP 7.2 support in MediaWiki 1.35; require PHP 7.3.19. This is a placeholder so tasks that require PHP 7.4 can block on it, there is no current plan to drop 7.3 support yet.

Related Objects

StatusSubtypeAssignedTask
Stalledtstarling
StalledNone
StalledNone
StalledNone
StalledNone
OpenNone
ResolvedDzahn
Resolvedhashar
ResolvedJdforrester-WMF
ResolvedLadsgroup
ResolvedMoritzMuehlenhoff
Resolvedjijiki
ResolvedMoritzMuehlenhoff
ResolvedTrizek-WMF
ResolvedDzahn
Resolved Gilles
ResolvedDzahn
ResolvedRequestPapaul
Resolvedjijiki
DeclinedNone
ResolvedDzahn
ResolvedDzahn
ResolvedPapaul
ResolvedCmjohnson
ResolvedRequestCmjohnson
ResolvedRequestPapaul
ResolvedAndrew
ResolvedArielGlenn
ResolvedDzahn
ResolvedLegoktm
ResolvedPapaul
ResolvedDzahn
Declined Gilles
ResolvedVolans
ResolvedDzahn
ResolvedLegoktm
ResolvedPleaseStand
OpenNone
ResolvedJoe
OpenJMeybohm
ResolvedArielGlenn
OpenNone
Resolvedtstarling
OpenJdforrester-WMF
OpenJdforrester-WMF
ResolvedLegoktm
OpenLegoktm
OpenJdforrester-WMF
ResolvedDaimona
ResolvedDaimona
ResolvedJoe
ResolvedJMeybohm
OpenNone
ResolvedKrinkle

Event Timeline

Potentially we might want to do this for MW 1.38? PHP 7.3 leaves official security support in five weeks' time: https://www.php.net/supported-versions.php

Potentially we might want to do this for MW 1.38? PHP 7.3 leaves official security support in five weeks' time: https://www.php.net/supported-versions.php

It's also in Debian oldstable (buster) which has another year of support though.