Page MenuHomePhabricator

New Beta features not automatically enabled after setting a local exception for this global preference
Open, Needs TriagePublicBUG REPORT

Description

Steps to Reproduce:

  1. I verify that the beta feature is enabled on Preferences.
  2. I "set an exception" for the global preferences for both the beta feature and the "autoenable beta features" preference.
  3. I then turn off the exception feature.

Actual Results:
When my preferences look like this:

image.png (1×841 px, 130 KB)

everything works fine, but when my preferences look like this:

image.png (1×842 px, 130 KB)

The beta feature does not always enable.

This is happening with "discussion tools". I have experienced this before with the "new wikitext editor" as well.

Expected Results:
The beta feature should enable on its own without any problem because I checked "Automatically enable new beta features" and set it as a global preference.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald Transcript

@Awesome_Aasim: Hi, which website is this about? Please include links in bug reports - thanks!

Aklapper renamed this task from Global Preferences Beta features "Automatically enable new beta features" not working as expected. to New Beta features not automatically enabled after setting a local exception for this global preference.Apr 1 2021, 9:12 AM

See also T170055

2 comments.

  1. Do keep in mind that the 1st button is labeled "Automatically enable most beta features" (emphasis added). Some beta features are not automatically enabled. If I remember correctly the options for "new wikitext editor" and "discussion tools" were previously (but since-changed) specific examples of that.
  1. I'm confused as to how Global Preferences are even showing on that page, for you.

Are those just direct screen-captures of the webpage you see?

  1. I'm confused as to how Global Preferences are even showing on that page, for you.

My Special:GlobalPreferences doesn't have a Beta features tab. It did previously since I enabled Discussion tools globally before it was available at enwiki, and it was, therefore, enabled there as soon as it was rolled out. My Special:Preferences#mw-prefsection-betafeatures does show the boxes for setting local exceptions to global preferences.

I can't confirm Awesome_Aasim's report since I don't use the auto enable preference.

Yep, that disappeared as well for me.

After doing a reset of Global Preferences, everything was back to normal.

I guess someone could include that information on MediaWiki.

Yep, that disappeared as well for me.

After doing a reset of Global Preferences, everything was back to normal.

I guess someone could include that information on MediaWiki.

Can you clarify if resetting global preferences restored the Beta tab in global preferences, or if it just fixed the tab in Special:Preferences