Page MenuHomePhabricator

Application Connection Error on metawiki
Closed, InvalidPublic

Description

When I go to https://meta.wikimedia.org/wiki/Special:OAuth/authenticate, I get:

Application Connection Error
Sorry, something went wrong connecting this application.

Unknown OAuth key, E006

Return to Special:MyLanguage/Main Page.

Going to the same URL in an incognito window gets me a normal login screen. I suspect what might be going on is I changed my password after the last time I authenticated through OAuth. If so, then the only problem is that this is a sub-optimal error message.

I'm going to leave this alone until you've had a chance to look at it.

I'm using Chrome Version 89.0.4389.114 (Official Build) (x86_64) on MacOS Big Sur.

Event Timeline

Reedy added a subscriber: Reedy.

What application are you trying to authenticate?

Hmmm, ok, I see what's going on. I started typing 'meta" in the url bar, and that's what Chrome auto-completed. I didn't really stop to think about it, just hit return.

I've got an app that runs on Toolforge (spi-tools and spi-tools-dev), which uses OAuth, and looking at it now, I see that it authenticates against meta.wikimedia.org. So, I guess Chrome captured the OAuth flow URL from that:

https://meta.wikimedia.org/w/index.php?title=Special:OAuth/authenticate&oauth_token=XXX&redirect_uri=https%3A%2F%2Fspi-tools-dev.toolforge.org%2Foauth%2Fcomplete%2Fmediawiki%2F

and decided to auto-complete it back to me minus the query strings. Weird. Let's chalk this up to Chrome being stupid.