Page MenuHomePhabricator

SULWatcher not compatible with new python versions (3.6+)
Closed, ResolvedPublic

Description

  File "/home/taavi/src/stewardbots/SULWatcher/SULWatcher.py", line 551
    global stop_event, watcher, bot1, bot2, bot3
    ^
SyntaxError: name 'bot1' is used prior to global declaration

This is warning on 3.5, and erroring in 3.6+.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 679705 had a related patch set uploaded (by Majavah; author: Majavah):

[labs/tools/stewardbots@master] SULWatcher: Remove use of globals, cleanup

https://gerrit.wikimedia.org/r/679705

Change 679705 merged by jenkins-bot:

[labs/tools/stewardbots@master] SULWatcher: Remove use of most globals, cleanup

https://gerrit.wikimedia.org/r/679705