Page MenuHomePhabricator

VisualEditor not symlinked when upgrading from mediawiki 1.31.14 to 1.35.1
Open, Needs TriagePublic

Description

Hello,

On a Debian 10, I was using a mediawiki 1.35.1 with VisualEditor sitting in /var/lib/mediawiki/extensions/VisualEditor.
I installed it using your package (thank you).

Since MW 1.35, VisualEditor is now part of the core extensions, and thus, appears in /usr/share/mediawiki/extensions-core/

After have add the debian backport source and upgraded MW, I see that the old /var/lib/mediawiki/extensions/VisualEditor is still used, making it crash when trying to use (a click on "edit" in a page leads to a "blink" and no more action).
Removing this bare folder and replacing it with the adequate symlink leads to happiness and colorful unicorns.

Thank you.

Nicolas

Event Timeline

I'll need to test to be sure, but I'm guessing apt/dpkg decided to not create the symlink because your folder already existed there? That really isn't a great failure condition though.

I'll need to test to be sure, but I'm guessing apt/dpkg decided to not create the symlink because your folder already existed there? That really isn't a great failure condition though.

This is more than likely the case.
And yes, this is not a great failure, though I had hard times explaining to my users that they had to switch back using the plain old raw wiki editor.