Page MenuHomePhabricator

Give "back to top" button
Closed, DeclinedPublic

Description

Author: hue

Description:
Is it possible to add a "back to top button".

The content is generalized in the beginning of every article through points (1,2,3, etc) and subpoints (1.1,1.2,1.3, etc) and it's great. But in very long articles would be nice to have this button after the end of every point or subpoint for better and faster navigation on the page and between seperate points.


Version: unspecified
Severity: enhancement

Details

Reference
bz26032

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 11:14 PM
bzimport set Reference to bz26032.
bzimport added a subscriber: Unknown Object (MLST).

For if/when this is implemented, a possible way to aavoid the ugly repeating 'back to top' links all over the place, a solution would be having it 'float' in a fixed position on the bottom left. As part of the sidebar but staying fixed when scrolling down. Avoids having it duplicate and adds that it is always in the same place.

I like Krinkle's floater idea! Giving this to Trevor since it is UI and he doesn't have enough of these yet.

Trevor:
This report has been in ASSIGNED status for more than one year and you are set as its assignee. In case that you are not actively working on a fix, please reset the bug status to NEW/UNCONFIRMED.
In case you do not plan to work on a fix in the near future: Please also edit the "Assigned To" field by clicking "Reset Assignee to default", in order to not prevent potential contributors from working on a fix. Thanks for your help!
[assigned>=1y]

Change 108306 had a related patch set uploaded by Jforrester:
Go to top button for pages. Implements go to top button with smooth scrolling. Hidden when on top of page and appears when scrolled down to some extent. Configurable-Enabled by default. Can be disabled by using "$wgShowTopButton = false;" in LocalSettings

https://gerrit.wikimedia.org/r/108306

Hi I submitted this patch through online gerrit uploader. Can someone review the patch?
https://gerrit.wikimedia.org/r/108306

Also I am new here so please tell if there is a better way to write the patch or if something else is wrong in the commit.

Created attachment 14339
Back to top button implemented using JQuery

My patch had a few errors as indicated by the notification bot.
I fixed them but I couldn't make a change as I hadn't submitted the patch through git-review.
I am uploading the new patch here. Please someone review it.

Attached:

(In reply to comment #6)

Created attachment 14339 [details]
Back to top button implemented using JQuery
My patch had a few errors as indicated by the notification bot.
I fixed them but I couldn't make a change as I hadn't submitted the patch
through git-review.
I am uploading the new patch here. Please someone review it.

Can you please submit it as a new patch via the uploader? (We can mark the old one as abandoned)

Attached:

Change 108306 abandoned by Jforrester:
Go to top button for pages

Reason:
Newer version in I866cd88201948177da2fec3cc9d4c713bb39bc0f.

https://gerrit.wikimedia.org/r/108306

Change 108323 had a related patch set uploaded by Jforrester:
Go to top button for pages

https://gerrit.wikimedia.org/r/108323

Jorm added a comment.Feb 11 2014, 3:00 AM

This bug should likely be closed WONTFIX, at least in regards to Foundation wikis. I have left comments on the gerrit change to this effect.

If this is a feature desired by 3rd Party wikis, it should be bundled into an extension rather than into core.

(In reply to comment #11)

This bug should likely be closed WONTFIX, at least in regards to Foundation
wikis. I have left comments on the gerrit change to this effect.

Can you please elaborate on why you think this is a complete non-starter for MediaWiki core?

Imagine something like [[mw:Requests for comment/Clickable section anchors#Option 2]] but with an additional up arrow icon to return back to the top of the page. If implemented well, I think this would be a net benefit to readers and users. Since we're discussing a core functionality of any MediaWiki wiki (the ability to create headers), it would make sense to add such capability directly into core.

I'm interested to hear what others think.

I don't think there should be a link for every section header as that would look cluttered and unprofessional. I like the idea of back to top / back to TOC links, but I think it should be a single static link somewhere on the page (bottom corner?).

Change 108323 abandoned by Krinkle:
Go to top button for pages

Reason:
Closing change as the implementation has various issues, patch author has not responded in several months, and there is some discussion on the bug report about whether this feature should be in core after all usability/design wise.

https://gerrit.wikimedia.org/r/108323

Jorm removed a subscriber: Jorm.Dec 26 2015, 7:24 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 26 2015, 7:24 PM
Volker_E closed this task as Declined.Jan 5 2017, 10:12 PM
Volker_E added a subscriber: Volker_E.

Closing “Declined” under current consideration. There is no clear advantage of adding this feature versus more visual clutter/cognitive overload concerns.