Page MenuHomePhabricator

iw links not displayed in the side menu if new vector layout is activated
Closed, ResolvedPublic

Description

Since 6 may 2021 i notice that the iw links on wikipedia pages are no longer displayed if the new vector interface is activated, while the iw-links continue to be displayed correctly if the old vector skin is used. According to my experience this is the case for all language versions of wikipedia.

2021-05-07 07_48_25-Category_21 BC deaths - Wikipedia — Mozilla Firefox - new vector skin.png (1×1 px, 184 KB)
2021-05-07 07_48_25-Category_21 BC deaths - Wikipedia — Mozilla Firefox - legacy vector skin.png (1×1 px, 251 KB)

Event Timeline

Robby triaged this task as High priority.May 7 2021, 6:06 AM

as it is according to my findings applicable to all pages in all language versions

Lydia_Pintscher added a subscriber: ovasileva.

It seems they have been moved to the upper right corner:

image.png (226×572 px, 8 KB)

Adding the team working on that.

On, say, Portuguese Wikipedia the language links are still appearing on the left in the new style:

image.png (988×506 px, 90 KB)

I think the issue is that the Commons link doesn't seem to be displayed in the new version on en at all - it's not in the 'languages' list (it's not a language), and while the wikisource link is still on the left, Commons has vanished.

Indeed it has been moved to the upper right corner. This is not that easily to be detected by users and should be well explained and indicated very clearly to users. Moreover with not even the language link to the language defined for the userinterface visible by default it will be dificult to detect by users as well as additional clicks as you have first on the x languages button and then you haveto search for the language youz would like to switch to. This should be improved.

Aklapper raised the priority of this task from High to Needs Triage.May 7 2021, 8:22 AM
Aklapper added a project: Desktop Improvements.

@Lydia_Pintscher - this is expected. We're moving them to the upper right corner for the new version of vector. For wikidata and commons, we'll go back to the old behavior once T281968: Remove language button from commons is done

@Robby - In terms of visibility, we'll be performing an A/B test to compare clicks to the old vs new version and iterate afterwards, but so far our qualitative tests have shown good results for the new vs old location with users being able to find languages in the new location up to 4x faster than the old (see https://www.mediawiki.org/wiki/Reading/Web/Desktop_Improvements/Repository/Language_Switching_User_Tests and https://www.mediawiki.org/wiki/Reading/Web/Desktop_Improvements/Features/Language_switching#User_testing). We will also be adding the list of suggested languages to the top of the collapsible list as in T282037: Suggested language list not available for ULS version in new language button

@ovasileva and the Commons link? <s>Ah, just seen your reply on that point, sorry.</s> Ah, no, that's about the language links on Commons, not the missing Commons link in the sidebar here...

@ovasileva and the Commons link? <s>Ah, just seen your reply on that point, sorry.</s> Ah, no, that's about the language links on Commons, not the missing Commons link in the sidebar here...

To clarify - do you mean the commons link available in the sidebar on other wikis? If so, no changes there. I think the article example above just didn't have any entries on commons. For all wikis with multiple language versions, this is the expected behavior (no change to the "in other wikis" links):

Screen Shot 2021-05-07 at 11.48.27 AM.png (1×2 px, 1 MB)

For wikis that support multiple languages, no changes are expected for now (once we fix the current bug in T281968: Remove language button from commons )

Adding an example from ptwiki:

Screen Shot 2021-05-07 at 11.53.55 AM.png (1×2 px, 1 MB)

Since the new version of the skin is available there by default, we will be deploying the language button a bit later once we've explored any other issues that we encounter in production that we might not have caught in our testing environment.

It should be displayed for this category, I see it:

image.png (864×509 px, 126 KB)

I haven't tried with new vector though (the content is too narrow for my liking).

Ah! Someone had deleted the category, I guess I was seeing the cache. Category undeleted, should be visible now @Robby ?

Robby claimed this task.

indeed now I see the iw links and I will close this ticket