Page MenuHomePhabricator

httpd-fcgi image is failing validation using its own test.sh
Closed, ResolvedPublic

Description

Deploying shellbox to staging failed because the httpd-fcgi image configured was still using "www-data" user. The httpd-fcgi image was updated to use numerical UIDs in 2.4.38-3 but that version was never published to the registry. I tried to build 2.4.38-4 just now and it fails because of test.sh not working:

...
2021-05-26 22:45:45,778 [docker-pkg-build] INFO - Successfully built 4d57c64823fb (image.py:210)
2021-05-26 22:45:45,787 [docker-pkg-build] INFO - Successfully tagged docker-registry.discovery.wmnet/httpd-fcgi:2.4.38-4 (image.py:210)
2021-05-26 22:45:45,787 [docker-pkg-build] INFO - Removing build context /tmp/docker-pkg-httpd-fcgiorgomwtr (image.py:491)
2021-05-26 22:45:45,812 [docker-pkg-build] ERROR - Verification of image docker-registry.discovery.wmnet/httpd-fcgi failed with return code 2 (image.py:448)
2021-05-26 22:45:45,813 [docker-pkg-build] ERROR - -- output: None (image.py:450)

Event Timeline

Marostegui triaged this task as Medium priority.May 27 2021, 5:13 AM
Marostegui removed a project: SRE.
Joe raised the priority of this task from Medium to High.

Change 696029 had a related patch set uploaded (by Giuseppe Lavagetto; author: Giuseppe Lavagetto):

[operations/docker-images/production-images@master] httpd-fcgi: fixes to functionality and tests

https://gerrit.wikimedia.org/r/696029

Joe renamed this task from httpd-fcgi image is not using numerical UIDs to httpd-fcgi image is failing validation using its own test.sh.May 27 2021, 9:30 AM

This turned out to be more issues than I thought. There were several small issues with the test.sh script, but also a larger issue with the actual apache configuration, both fixed in the patch above.

Change 696029 merged by Giuseppe Lavagetto:

[operations/docker-images/production-images@master] httpd-fcgi: fixes to functionality and tests

https://gerrit.wikimedia.org/r/696029

# build-production-images 
== Step 0: scanning /srv/images/production-images/images ==
Will build the following images:
* docker-registry.discovery.wmnet/httpd-fcgi:2.4.38-4
== Step 1: building images ==
/bin/bash
## Defaults behave as expected PASS
## Enable debug logging    PASS
## Connect to fcgi using a socket  PASS
## Server signature can be changed PASS
* Built image docker-registry.discovery.wmnet/httpd-fcgi:2.4.38-4
== Step 2: publishing ==
Successfully published image docker-registry.discovery.wmnet/httpd-fcgi:2.4.38-4
== Build done! ==
You can see the logs at ./docker-pkg-build.log