Page MenuHomePhabricator

Python 3.5.0: fails when parsing requirements
Closed, ResolvedPublic


Python 3.5.0 comes with setuptools 18.2 but 20.8.1 or higher is needed. This should be checked first in

Traceback (most recent call last):
  File "C:\pwb\GIT\core\", line 215, in <module>
    if not check_modules():
  File "C:\pwb\GIT\core\", line 186, in check_modules
    for requirement in pkg_resources.parse_requirements(dependencies):
  File "C:\Python35\lib\site-packages\pkg_resources\", line 2930, in parse_requirements
    "version spec")
  File "C:\Python35\lib\site-packages\pkg_resources\", line 2906, in scan_list
    raise RequirementParseError(msg, line, "at", line[p:])
pkg_resources.RequirementParseError: Expected ',' or end-of-list in requests>=2.20.1,<2.26.0;python_version<"3.6" at ;python_version<"3.6"

Event Timeline

Xqt triaged this task as Medium priority.Jul 20 2021, 7:31 AM

Change 705619 had a related patch set uploaded (by Xqt; author: Xqt):

[pywikibot/core@master] [bugfix] Check for outdated setuptools first

Change 705619 merged by jenkins-bot:

[pywikibot/core@master] [bugfix] Check for outdated setuptools first