Page MenuHomePhabricator

Update Lilypond in Shellbox container to >= 2.22.0,
Closed, ResolvedPublic

Description

T49578 and an issue mentioned in T257066#7229688 depend on this.

Debian 10 (buster?) backports has Lilypond 2.22.0, so perhaps this should depend on a task to update Lilypond? Lilypond itself is now at 2.22.1, with some worthwhile improvements

(I don't know how WMF handles package updates.)

Event Timeline

Legoktm renamed this task from Update Lilypond on Debian to >= 2.22.0, to Update Lilypond in Shellbox container to >= 2.22.0,.Jul 22 2021, 9:30 PM
Legoktm claimed this task.
Legoktm added projects: Packaging, serviceops.

I spent a while yesterday trying to package 2.22.1 and eventually gave up after fighting the way guile is embedded in the package and all the various patches on top of that. Using 2.22.0 from buster-backports is trivial so let's go with that for now.

Change 707416 had a related patch set uploaded (by Legoktm; author: Legoktm):

[mediawiki/libs/Shellbox@master] Install lilypond 2.22.0 from buster-backports

https://gerrit.wikimedia.org/r/707416

Change 707416 merged by jenkins-bot:

[mediawiki/libs/Shellbox@master] Install lilypond 2.22.0 from buster-backports

https://gerrit.wikimedia.org/r/707416

Change 707458 had a related patch set uploaded (by Legoktm; author: Legoktm):

[operations/deployment-charts@master] Bump shellbox to 2021-07-23-172126-score

https://gerrit.wikimedia.org/r/707458

Change 707458 merged by jenkins-bot:

[operations/deployment-charts@master] Bump shellbox to 2021-07-23-172126-score

https://gerrit.wikimedia.org/r/707458