Page MenuHomePhabricator

Maps place_labels layer is not applying i18n at zoom level less than 10
Open, HighPublic

Description

Steps to Reproduce

From T287213#7274783
I don't know which cluster I get tiles from, but it it appears that all city names on all zoom levels are unlocalized now. E.g. on https://maps.wikimedia.org/?lang=fr nodes 27490597 and 428339515 no longer appear respectively as Saint-Pétersbourg and Varsovie. Interestingly, country names, presumably from nodes like 432425060 and 424314830, are still localized.

  1. Access https://maps.wikimedia.org/?lang=fr
  2. nodes 27490597 and 428339515 no longer appear respectively as Saint-Pétersbourg and Varsovie

Expected Results

  • i18n labels are applied correctly

Actual Results

  • place_labels layer is no applying i18n

Environments Observed

  • production

Event Timeline

MSantos renamed this task from [Bug] TITLE to Maps place_labels layer is not applying i18n.Aug 12 2021, 10:37 AM
MSantos triaged this task as High priority.

Change 712112 had a related patch set uploaded (by MSantos; author: MSantos):

[mediawiki/services/kartotherian@master] Bump osm-bright-source in tilerator and kartotherian

https://gerrit.wikimedia.org/r/712112

Change 712112 merged by jenkins-bot:

[mediawiki/services/kartotherian@master] Bump osm-bright-source in tilerator and kartotherian

https://gerrit.wikimedia.org/r/712112

Arjunaraoc renamed this task from Maps place_labels layer is not applying i18n to Maps place_labels layer is not applying i18n at zoom level more than 9.Sep 9 2021, 7:03 AM
Arjunaraoc renamed this task from Maps place_labels layer is not applying i18n at zoom level more than 9 to Maps place_labels layer is not applying i18n at zoom level less than 10.Sep 9 2021, 1:08 PM

I think this is fixed now right @MSantos ?

Pikne added a subscriber: Pikne.

I suppose it's fixed. Localized names have been displayed again for a while now.

Indeed, the issue has resurfaced for other languages as well.

Does this have got something to do with switching to tegola lately (T280767)? Little awhile ago, when osm-intl source yet didn't serve tegola-based tiles, I noticed that osm-tegola tiles showed different data. Now I also notice that Wikimedia tiles have some old data that was changed several months ago in OSM. So is it possible that tegola-based tiles just haven't been updated in recent months, and since given issue was fixed?

Change 751490 had a related patch set uploaded (by MSantos; author: MSantos):

[operations/deployment-charts@master] tegola: place_label i18n fix

https://gerrit.wikimedia.org/r/751490

Change 751490 merged by jenkins-bot:

[operations/deployment-charts@master] tegola: place_label i18n fix

https://gerrit.wikimedia.org/r/751490