Page MenuHomePhabricator

Bundle Linter extension with MediaWiki
Open, Needs TriagePublic

Description

Linter is a dependency for DiscussionTools so this would be needed for T290464: Bundle DiscussionTools extension with MediaWiki.

  • Passed security review or already Wikimedia deployed
  • Voting CI structure tests
  • Runs MediaWiki-CodeSniffer
  • Runs phan
  • Supports MySQL, SQLite, and Postgres (uses abstract schema)
  • GPL v2 or later compatible license (GPL v2)
  • Extension's default configuration provides optimal experience (it's primarily useful as a dependency so the config doesn't matter much)
  • Tested with web installer
  • Any relevant dependencies/enhancing extensions also bundled (none)

Event Timeline

Tgr edited projects, added MW-1.37-release; removed MW-1.38-release.

Turned out to be pretty simple, could as well go into the current release.

Change 720490 had a related patch set uploaded (by Gergő Tisza; author: Gergő Tisza):

[mediawiki/tools/release@master] Add DiscussionTools to the default MediaWiki bundle

https://gerrit.wikimedia.org/r/720490