Page MenuHomePhabricator

Move Interlanguage link on Main page to the top at euwiki
Closed, ResolvedPublicBUG REPORT

Description

List of steps to reproduce (step by step, including full links if applicable):

  • Go to eu.wikipedia.org or fr.wikipedia.org
  • Try to find the language link

What happens?:

irudia.png (472×1 px, 85 KB)

irudia.png (436×1 px, 60 KB)

The link appears just below everything

What should have happened instead?: it should go upside, as in the articles.

Software version (if not a Wikimedia wiki), browser information, screenshots, other information, etc:

Event Timeline

Aklapper renamed this task from Interlanguage link in Main page is under categories in New Vector to Interlanguage link on Main page is below categories in New Vector.Sep 7 2021, 12:45 PM
Theklan reopened this task as Open.EditedSep 7 2021, 6:15 PM

Making things on purpose worse can't be an argument for closing a bug report. The style is broken and should be solved. If there's no option to solve it globally because someone has decided that burying it is better, it should be solved locally.

Theklan renamed this task from Interlanguage link on Main page is below categories in New Vector to Move Interlanguage link on Main page to the top at euwiki.Sep 7 2021, 6:16 PM
Aklapper closed this task as Invalid.EditedSep 7 2021, 6:19 PM

This is not a bug but expected behavior, as I already explained. If you think that the current behavior should be reconsidered, then I'd suggest raising this topic on https://www.mediawiki.org/wiki/Talk:Reading/Web/Desktop_Improvements to discuss actual use cases and underlying problems with the current behavior.
(This task lacks a use case.)

If the expected behavior is a bug, then this is a bug. Please, stop closing bug reports that hasn't been solved.

Hi @Theklan - there's a couple of next steps we are planning for this. We are currently evaluating the results of the A/B test for language that will allow us to evaluate whether the change had its intended effects. With the main page, we are expecting some amount of decrease of language switching, but will iterate on the design if that decrease is below our expectation. As you can see from the comments on T276140: Move language button to the bottom of Main pages there are some technical difficulties to introducing the language button on the main page since the location of the new button is not available, thus we could land on a different design solution (cc @alexhollender) We will also be re-evaluating this towards the end of the project.

Well, I have been working on web design and the obvious design errors, especially if those are something in the core of the project, can't be left for the end. This is a real problem, independently from the A/B test result of the new switcher. The interwiki link in the main page, that is, in the most visited page of any given wiki, is not visible at all. Interwiki links are really important, so this is currently a BUG, and should be solved.

I agree that language switching from the main page should be as easy as it is from any other page. As a point of reference, using Legacy Vector I am unable to see the interlanguage links without scrolling:

Screen Shot 2021-09-07 at 5.03.50 PM.png (783×1 px, 568 KB)

Therefore I wonder if we've created a bug, or if we've just made the situation worse because now you have to scroll further down the page?

I don't know much about the Main page, and what constraints exist, but I wonder if it would be worth considering adding a title to the Main page to simplify this situation? We could even use it as an opportunity to add some personalization into the interface:

Logged-outLogged-in
image.png (1×2 px, 1 MB)
image.png (1×2 px, 1 MB)

The title is as display:hidden on most Wikipedias. So the interwiki links should be added in the top regardless of the title. As it was suggested by @Aklapper, I added this idea to the MediaWiki talk, but, as expected, there are no answers there. So I will reopen again this, as it is not solved in any way.

https://www.mediawiki.org/wiki/Talk:Reading/Web/Desktop_Improvements#Interwiki_links_SHOULDN'T_be_buried_in_the_bottom_of_the_page_at_euwiki

The title is as display:hidden on most Wikipedias. So the interwiki links should be added in the top regardless of the title. As it was suggested by @Aklapper, I added this idea to the MediaWiki talk, but, as expected, there are no answers there. So I will reopen again this, as it is not solved in any way.

https://www.mediawiki.org/wiki/Talk:Reading/Web/Desktop_Improvements#Interwiki_links_SHOULDN'T_be_buried_in_the_bottom_of_the_page_at_euwiki

Do you know why the title is hidden on most wikipedias? I would guess that it's because it doesn't add any value to the page. However with the new position of the language switcher next to the title I think it makes sense to add both elements to the main page. In other words I think it looks weird to just put the language switcher there without the title.

The ticket on T179159 has been open since 2017 and has a lot of useful background. I am concerned that this task is fragmenting the conversation around design and technical challenges. I would suggest choosing one ticket and trying to capture everything we know so far in the description before it becomes too fragmented.

Do you know why the title is hidden on most wikipedias? I would guess that it's because it doesn't add any value to the page.

The title is hidder on most wikipedias because the Main Page is presented just there, with a better mesaage. This is something communities have made all around, so any solution implemented in design SHOULD take into account that the most visited page in one and every Wikipedia is not compatible with the design proposed. There's not any Title and there won't be any title, because the main pages are highgly debated pages. If you try to force a title only to show the language selector, then you will have communities overriding it by simply using !important.

So, the solution must aknowledge this and can't be just hiding or burying the language selector because we didn't take into account that this is a priority when it was designed. I don't know which is the global solution, or even if there is one. But the language selector at euwiki SHOULD go in the upper side. And, who knows, maybe English Wikipedia decides that it must go inside this section:

irudia.png (401×1 px, 56 KB)

Can we have a simple hook that added to the HTML code of the Main Page shows it wherever the design fits? If so, that would be a partial solution, where every design must decide where to put it.

If the HTML code is not a solution, then, a global solution must come, but we can't wait a year (or since 2017 per @Jdlrobson) because the interwiki link now is virtually absent at euwiki and frwiki.

@Theklan I just want to point out that if you want the link at the top you can do this with an editor to MediaWiki:Vector.css without any code changes:

.page-Azala #p-lang-btn {
    position: absolute;
    right: 0;
    top: 8px;
}

Then THERE'S a solution! Not the best one, but there's one:

irudia.png (417×1 px, 85 KB)

Theklan claimed this task.

This bug is solved for Basque language. The documentation of the new Vector should mention this issue, as there will be around 800 wikis who will need a css change to put the interwiki menu in its position.

Thanks @Jdlrobson

@Theklan I think it's great you found a solution.

I request that you consider showing the title on the main page in addition. I think it would be an improvement for two reasons:

  1. the language switcher looks out of place, and the top of the balance looks unbalanced with the current solution you have
  2. for the sake of consistency I think it would be better to have the page title there, as almost every other page does

Since you are the first Wikipedia to do this I think it would be very helpful to set a good example. I am worried that other Wikipedias will start copying what you have done, and then it will be more difficult to ask them to consider adding the title back in afterwards.

I realize that it will probably look wrong or weird to you at first. I therefore would ask that you take a few days to consider the images below, and think about how you could a) use the page title well, and b) update the main page so it doesn't feel repetitive. Thanks for your consideration : )

Comparison:

your current versionwith page title
Screen Shot 2021-09-22 at 5.15.17 PM.png (460×1 px, 472 KB)
image.png (924×2 px, 1 MB)

The main page doesn't have a title. And you won't convince most Wikipedias about it. Forget about convincing the English Wikipedia.

The error here is in the design concept. The design is trying to patch over a previous one, instead of solving the great problems Vector has (1990s feel). The decission to keep nearly everything from the previous designs will cause unbalances, but the communities can't solve those unbalances because the reach of the redesign is poor and full of concept errors.

There s a button over there, with the name "Azala" that means Main page. If we add another title, is completely redundant and, therefore, not necessary. In all the redesign process I haven't seen any mock-up of the Main page, not even an attempt to redesign it. The only thing is changing is moving the links from a place to another, making users click twice for things we were clicking once. There's no mock-up for special pages, there wasn't a solution for adding interlanguage links, the top menu (Article, Talk...) is floating nowhere... no one seems to talk about a real redesign, we are doing make-up and we are doing it wrongly.

There s a button over there, with the name "Azala" that means Main page. If we add another title, is completely redundant and, therefore, not necessary.

The page title doesn't have to say "Azala", it could say "Welcome to Wikipedia", it could say "Welcome [Username]", or something else. We could use the title in a helpful way. I am asking for your help and collaboration here.

In all the redesign process I haven't seen any mock-up of the Main page, not even an attempt to redesign it.

The Main Page is defined by the community. We have not proposed any changes to it on purpose. Regarding language switching, I made several mockups which you can see here: T276140.

There's no mock-up for special pages, there wasn't a solution for adding interlanguage links, the top menu (Article, Talk...) is floating nowhere... no one seems to talk about a real redesign, we are doing make-up and we are doing it wrongly.

I am not sure what you mean by these comments, I don't understand your point? It seems like you are focusing on the small number of things that are wrong. If you want to say mean or disrespectful things, why? Please keep in mind that the redesign is not yet complete, and assume good faith. Of course we miss certain things and then work with the community to figure them out. If you have ideas for improvements please share them with us.

I want to help, but I'm doing this as a volunteer, and every time I use my time to raise a concern I find or vacuum, or as in this case, days of closing the issue, contempt and even saying that the case is closed, when it is evident that it wasn't.

I have been trying to help with the idea of a redesign since it started (and that's why euwiki is a test case, exactly). Let's face it: there is no redesign, only a redistribution of things that were in some place to another new place, in some situations with worst results. I assume good faith, so I think that the problem is lack of knowledge of what every button does. That's the only logical output I have when I think why the login button has disappeared. Or why no one ever thought on where to put the interlanguage link in the most visited page of every wiki. Or why there wasn't a interlanguage linking link for new pages when the iteration was done. Or why we have two buttons for alerts and messages but we don't have one to access our talk page. Or why we have now three clicks for opening a new tab for another language when this could be done with only one.

I want to help. With a redesign. This is not a redesign. This (except the Hitler part) is a redesign: https://www.behance.net/gallery/101842737/Wikipedia-Rebranding. I already mentioned it when it was first tested: https://www.mediawiki.org/wiki/Reading/Web/Desktop_Improvements/Prototype_testing/eu#Theklan. Do we want to move things around? Then we will have something that is obsolete. We can do it, but you must listen to what people who wants change is saying. Don't listen to the people who doesn't want change, because then we will be static forever. And they don't want change, so having the possibility to do 100, doing only 10 because someone said that 0 was better won't convince the static people nor the needs we have.

Does anyone want to redesign Wikipedia? Let's work on that. But if the final aim is patching, then we must assume that those patches are only good if they make our volunteering better. If they are going to make things worse, if we are going to waste our time fighting here or there to be heard... then we are wasting both your energy, donor's money and our time.

And I think that this is the idea. I will continue sharing obvious usabilty errors that are coming because of badly designed dead ends. Whenever we want to talk about a redesign, I will still be here helping to make Wikipedia better.

The page title doesn't have to say "Azala", it could say "Welcome to Wikipedia", it could say "Welcome [Username]", or something else. We could use the title in a helpful way. I am asking for your help and collaboration here.

Welcome 192.123.4.25. Definitively a bad idea. No, Main Pages don't have titles and won't have because the interwiki link place doesn't aknowledge this fact for the most visited page in every Wikipedia. Every Wikipedia has a welcome sentence there, not as a title but as a text. In euwiki you have there, in the scrolling text.

@Theklan we are not doing a redesign, we are making a series of improvements to the interface based on research, community request, community developed gadgets, and user scripts. If you are angry that we are not doing a redesign I am sorry, but please stop making rude comments here, it is not helpful to anyone.

I am also confused, because it seems like you want a redesign but you also seem unwilling to consider a small change: adding a title to the main page. It would be simple to remove the "Welcome" from the text of the page and instead use the title for that. And again, "Welcome 192.123.4.25" — why focus on the edge case, and bring negativity? We can solve for that if we work together (just like we're doing on the task about the Sandbox icon).

I am sorry some of your tasks have gotten closed, but being angry and upset is not going to make anything better. Please find a way to engage kindly. We are all working hard and this is a big, complex, challenging project.

I found a way to engage kindly: opening a bug report. It was closed. I reopened it. It was closed. I reopened it again. There was a solution using CSS. I closed it as solved.

And no, we are not doing a redesign. That's it. We are messing things around and then closing our ears when someone tells us that this change is making things harder.

That's why I closed this BUG: because the bug is solved. When the new vector make-up is deployed in all the wikis, someone will have to make CSS changes to nearly 800 Vector.css pages. But not at euwiki, because the bug is solved yet here. I don't want to solve all the mess that is happening: just solve the interwiki link at euwiki.

Thanks.

PD: I have many other petitions open about obvious usability issues. Most of them are ignored or even told that this obvious errors are a new feature. I will open tickets with every thing I see that is making things worse. If someone wants to talk about them, I will still be here.

@Theklan I am sorry your tasks have gotten closed. I understand how that might be confusing and frustrating. It happens sometimes by accident. It is not personal to you. When you created this task we already had T276140, which was in part a discussion about how to handle language switching on the Main page. I don't think it's fair, or correct, to say that our ears are closed, or that we are closing bugs without dealing with them. That is not the case.

It's great that you are opening bugs, but I don't think that is enough. We all need to be kind to each other as we discuss these bugs, possibly merge them into other discussions, etc.

And while this bug is fixed, you have created a new problem: the Main page on EU Wikipedia looks wrong. So I don't think your solution is finished in this case. Are you willing to work together to discuss modifications?

Yes, the Main page looks wrong, because we have to make a Main Page within the constraints of Vector. The interlanguage link is now where it should be. And for sure, I would like to have a modern looking site, but if we need to do it inside Vector, that won't be possible.

@Theklan we think that gradual changes are better received by this community than big redesigns. We have some constraints, and we have to make some compromises, yes. Over time we can work towards bigger changes. I'm sorry if this process is too slow for you.

Maybe by the end of the project we can get to something like this, and then continue to make more radical changes going forward. But in order to get there we need to work together, and make gradual changes.

image.png (1×2 px, 1 MB)

Are you willing to discuss the design of the Main page some more?

Sure, I want to discuss it. I tried to do that in the very first moment a new design was anounced. But that's not a mockup of the main page. I haven't seen any. Is there any design of an ideal main page?

@Theklan I haven't done any research on the main page, so I don't know what an ideal main page might look like. My understanding is that it is defined by the community. What do you think it should look like? I would be happy to make some mockups if you have ideas.

For now my thinking is limited to:

  • switching languages from the main page should be easy (and ideally consistent with switching languages on other pages). Other ideas I had for this are in the task description here: T276140
  • I would like to consider adding a title to the main page, to balance out the placement of the language switcher. I understand this poses new issues, and feels too constrained to Vector to you. If you are open to discussing this that would be great.

Here you have some good ideas. Adding a title is not one of them. And the WHOLE issue is that we are doing a redesign reorganization of items without even thinking on our most visited page. That's the problem. And it won't be solved adding a title, because the lack of proposals and the constraints we have to do that are in the center of the stage.

@Theklan the main page gets very few visits compared with article pages. We are thinking through the layout of article pages first. We have a good location for the page title and the language switcher on article pages. From there, the general structure of the Main page should follow (of course the contents can be different).

It sounds like you are not willing to have a reasonable discussion about how to handle the Main page. I am sorry about this because you seem like a passionate Wikipedian with many good ideas. I will focus my energy on a different Wiki and hope that they will be open minded about discussing article switching + a title on the Main page. Thanks!

Good luck in that endeavour. You won't convince the 800+ wikis about inserting a title there because there wasn't any plan for the Main page at any moment of the process. And it's a pity, because the Main page is the most visited page in all wikis. You can deny it, but the data is clear: https://stats.wikimedia.org/#/en.wikipedia.org/reading/top-viewed-articles/normal|table|last-month|(access)~desktop*mobile-app*mobile-web|monthly

In English Wikipedia there are 181 million views every month, 6 million hits per day. I would be really happy to discuss how to make the Main page appealing, we have tried it at the Basque wikipedia and there are other very good approaches, i.e. Catalan Wikipedia. None of them could get rid of the constraints of doing things inside a small window (now smaller, by the way) derived from the rigidity of vector. We don't have a grid system, we have to do really complex things to have an slider, the Main page is cached so we can't show random objects easily.

I'm not the responsible for this make-up. Every time someone has approached me and asked about my impressions I have said the same: this is in the middle of nowhere. The slow change we are experiencing, with really weird decissions (like deleting the possibility to link new articles with other languages or hiding the login button) is making things worse. The question is: is someone willing to redesign the Main page (6 million hits per day in English) with an interesting proposal (that won't be done in English Wikipedia because of conservativism) but can be done in smaller Wikipedias with spirit of innovation? If the answer is yes, and it's not limited to hiding the login button, then I will be really happy to work on this. If the answer is no, then all this bugs will trigger a task. Because annoying volunteers with bad decisions that can't be discussed (and if discussed you are silenced, the tasks closed or forced into oblivion) is the worst way to build the best solution.

for future discussions with other wikis, documenting this issue with placing the language switcher at the top of the main page in a custom way (possibly would be resolved by including the entire page title element):

Screen Shot 2021-10-04 at 11.34.16 AM.png (507×1 px, 147 KB)

The problem there is the globalnotice, that falls inside the page content, but it shouldn't be there, it should be full width and banner-like. The same issue happens when the width is limited to all the pages using PAGEBANNER extension.

Hello @alexhollender. I have been looking at options to add a title to the Main Page as suggested, mainly because the typewriter effect was giving weird results in lower resolution displays (some University projectors) so I thought to separate the "Welcome to Wikipedia" and the typewriter effect and take your suggestion for a title. The problem is that changing the title from "Azala" to "Welcome to Wikipedia" is not something that can easily be done without using css or js, so it wouldn't be effective: https://eu.wikipedia.org/w/index.php?title=Azala&oldid=8745984

Do you have a solution to change the title name without changing the Main page address? If so, this solution could be something that could be evaluated by other Wikipedias. If not, then the given solution is still unpractical.

Thanks.

Also, the language selector doesn't fit the line:

irudia.png (637×1 px, 426 KB)

We can update the code to allow more control over customizing the main page heading. I think that makes a lot of sense based on what editors do for the main page.

Test URL: https://patchdemo.wmflabs.org/wikis/50a2dd581d/wiki/Main_Page
Title source: https://patchdemo.wmflabs.org/wikis/50a2dd581d/w/index.php?title=MediaWiki:Mainpage-title&action=edit
Patch: https://gerrit.wikimedia.org/r/c/mediawiki/core/+/734420

You can login with Patch Demo / patchdemo1 to try it out.

This might also address the use case of T255682 too.

Yes, this solution might work.


From: Jdlrobson <no-reply@phabricator.wikimedia.org>
Sent: Tuesday, October 26, 2021 12:31 AM
To: galder158@hotmail.com <galder158@hotmail.com>
Subject: [Maniphest] [Updated] T290480: Move Interlanguage link on Main page to the top at euwiki

Jdlrobson added a comment. View Taskhttps://phabricator.wikimedia.org/T290480

We can update the code to allow more control over customizing the main page heading. I think that makes a lot of sense based on what editors do for the main page.

Test URL: https://patchdemo.wmflabs.org/wikis/50a2dd581d/wiki/Main_Page
Title source: https://patchdemo.wmflabs.org/wikis/50a2dd581d/w/index.php?title=MediaWiki:Mainpage-title&action=edit
Patch: https://gerrit.wikimedia.org/r/c/mediawiki/core/+/734420

You can login with Patch Demo / patchdemo1 to try it out.

This might also address the use case of T255682https://phabricator.wikimedia.org/T255682 too.

TASK DETAIL
https://phabricator.wikimedia.org/T290480

EMAIL PREFERENCES
https://phabricator.wikimedia.org/settings/panel/emailpreferences/

To: Theklan, Jdlrobson
Cc: Jdlrobson, ovasileva, alexhollender, Aklapper, Theklan, Romain, Patafisik_WMF, Selby, Demian, JJMC89, Iniquity, Agabi10, Volker_E

[OT] @Theklan: Please remove unneeded full quotes, or use a standard delimiter line (-- , dash dash space), to keep comments more readable. Thanks a lot!

[OT] @Theklan: Please remove unneeded full quotes, or use a standard delimiter line (-- , dash dash space), to keep comments more readable. Thanks a lot!

I answered the message by e-mail. If this is a problem, the issue is on Phabricator, not mine.

[OT] @Theklan: It's up to you what you write in an email. Please remove unneeded full quotes when you write emails. Thanks.

I don't know why I get this hostility every time I make a comment. Is really toxic. I receive an e-mail, I click Reply, I write my reply and the rest of the code is added below. This is something Phabricator is doing.

[OT] @Theklan: I kindly asked you to keep comments in Phab more readable. I don't see any hostility in my request. All I asked for is when replying, please remove full unneeded quotes at the bottom. There is nothing that "Phabricator is doing"; this is something up to the sender of an email. Thanks for your understanding.

Now I'm answering your message by e-mail. Just click reply, add this sentence, and send.

[cid:9f8e6ad6-2154-4e3d-83c8-9f025bae28fc]


From: Aklapper <no-reply@phabricator.wikimedia.org>
Sent: Tuesday, October 26, 2021 9:58 AM
To: galder158@hotmail.com <galder158@hotmail.com>
Subject: [Maniphest] [Commented On] T290480: Move Interlanguage link on Main page to the top at euwiki

Aklapper added a comment. View Taskhttps://phabricator.wikimedia.org/T290480

[OT] @Theklanhttps://phabricator.wikimedia.org/p/Theklan/: I kindly asked you to keep comments in Phab more readable. I don't see any hostility in my request. All I asked for is when replying, please remove full unneeded quotes at the bottom. There is nothing that "Phabricator is doing"; this is something up to the sender of an email. Thanks for your understanding.

TASK DETAIL
https://phabricator.wikimedia.org/T290480

EMAIL PREFERENCES
https://phabricator.wikimedia.org/settings/panel/emailpreferences/

To: Theklan, Aklapper
Cc: Jdlrobson, ovasileva, alexhollender, Aklapper, Theklan, Romain, Patafisik_WMF, Selby, Demian, JJMC89, Iniquity, Agabi10, Volker_E

image.png (513×1 px, 27 KB)

[OT] @Theklan: Correct. And I kindly asked you not to do that, but strip unneeded full quotes.

Thanks @Aklapper for your valuable time. I don't have enough spare time in these last weeks and it's important someone has it.