Page MenuHomePhabricator

Special:RecentChanges - Add missing preferences for hide/show like for minor edits and patrolled edits
Closed, DeclinedPublic

Description

Both Watchlist and Recent changes have similar hide/show options when accessing the pages:
Hide/Show:

  • minor edits
  • bots
  • anonymous users
  • logged-in users
  • my edits
  • patrolled edits

For Watchlist all of these can be saved/rememberd through Special:Preferences so users don't have to click the links to get their preferred output every single time.

However for RecentChanges only visiblity of 'minor edits' and 'patrolled edits' can be saved. The others not.

Being able to remember these settings would save some time for users.


Version: 1.18.x
Severity: normal

Details

Reference
bz27050

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 11:19 PM
bzimport set Reference to bz27050.
bzimport added a subscriber: Unknown Object (MLST).
Krinkle created this task.Jan 30 2011, 8:17 PM

I am support this, hardcode defaults a bad practice.

See bug 7039 and bug 16957

Considering how long the hideanons option for watchlist was broken with no one noticing, I think perhaps some of these prefs should be removed (unnecessary prefs are evil, yadda yadda). Anyways, see comments on r81210

  • Bug 29696 has been marked as a duplicate of this bug. ***
  • Bug 7039 has been marked as a duplicate of this bug. ***
aaron added a comment.Nov 4 2011, 5:56 PM

Not sure if this is justified. I think maybe hidebots is worth it. I suppose people could usage gadgets too :)

bug 7039 contains a patch

patch from bug 7039 commited together with bug 16957 with gerrit 4350

(In reply to comment #7)

patch from bug 7039 commited together with bug 16957 with Gerrit change #4350

change abandoned, because (so many) new preferences are not assisted by mediawiki developer

I agree that is too many preferences.

I suppose they could easily be stored in a single entry though (JSON or serialized php). Or name them with clear prefixes and matching suffixes between rc and watchlist

related: bug 22213

John, you mentioned this in bug 64829 comment 8; I'd like to fix this bug as next on my list of bug 31882 dependencies, any suggestion? My first example is https://gerrit.wikimedia.org/r/#/c/131727/ , I don't plan to invest more time in similar patches before the first is merged.

Ciencia_Al_Poder renamed this task from Add missing preferences for hide/show like for minor edits and patrolled edits. to Special:RecentChanges - Add missing preferences for hide/show like for minor edits and patrolled edits.Jan 1 2015, 9:18 PM
Ciencia_Al_Poder updated the task description. (Show Details)
Ciencia_Al_Poder set Security to None.
Ciencia_Al_Poder removed subscribers: Unknown Object (MLST), bzimport.

I support to make MW remember all these options.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 19 2015, 6:18 PM
-jem- added a subscriber: -jem-.Sep 5 2017, 7:43 PM
Krinkle removed a subscriber: Krinkle.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptSep 6 2017, 1:31 AM
jmatazzoni closed this task as Invalid.Oct 9 2017, 9:10 PM
-jem- reopened this task as Open.Oct 12 2017, 5:52 PM

This task seems valid and useful; I can understand that it is declined with an explanation, but IMHO marking as invalid is not the right way to close it.

Catrope closed this task as Declined.Oct 12 2017, 6:00 PM
Catrope added a subscriber: Catrope.

In the new filters UI, you can save any combination of filters you like, and you can make a saved filter "default", which means it'll load when you open the page. So while there aren't actual separate preferences for each of these filters, that feature lets you do the same thing.