Page MenuHomePhabricator

vector skin, table and infobox overlap with each other (when using "narrow and widescreen" gadget)
Closed, InvalidPublicBUG REPORT

Description

vector skin, table and infobox overlap with each other, see here, on e.g. newest chromium:
https://en.wikipedia.org/wiki/Sam_Lammers

Event Timeline

Ivi104 renamed this task from vector skin, table and infobox overwrite each other to vector skin, table and infobox overlap with each other.Sep 19 2021, 8:39 PM
Ivi104 updated the task description. (Show Details)

another instance of similar here:

image.png (916×1 px, 388 KB)

another instance with the location, on pt wiki

image.png (370×1 px, 78 KB)

@Jdlrobson i saw in the techn news your name to ping ...

@ThurnerRupert: Thanks for reporting this. What exactly is "newest Chromium"? Please always include exact version info to avoid misunderstandings.

i saw in the techn news your name to ping ...

What exactly in tech news and where to find it? Please include references for statement. I only see Monobook mentioned in week 38, not Vector...?

Cannot reproduce with Chromium 93.0.4577.63 on https://en.wikipedia.org/wiki/Sam_Lammers?useskin=vector&useskinversion=1&safemode=1 but things look a bit strange indeed:

Screenshot from 2021-09-28 10-07-16.png (940×1 px, 388 KB)

I think this user has my "narrow and widescreen" gadget enabled. It doesn't work that well with the restricted width of the new vector. I havent' looked into making it compatible yet, and i's probably difficult, in that there is now a skin with two render modes, which I cannot easily detect with CSS I suspect. I mean, there's no body:not(.skin-newvector) I can use right ?

This indeed looks like a gadget problem.
It should go away with the disabling of gadgets. https://en.wikipedia.org/wiki/Sam_Lammers?safemode=1

in that there is now a skin with two render modes, which I cannot easily detect with CSS I suspect. I mean, there's no body:not(.skin-newvector) I can use right ?

For targetting the legacy skin you can use the skin-vector-legacy class. Work has begun on T291098

ah, i see, @TheDJ, @Jdlrobson, thank you so much! that is it, the narrow and widescreen gadget is enabled by default, can i close this task or you prefer to leave it open and change the title?

am trying minerva now. which looks quite clean with its icons, love it. even more i would love to have a skin which (1) keeps the default font of the browser / desktop environment, (2) uses the full width of the browser window, (3) has all menues in a separate screen which can be opened and closed by one keystroke or command, e.g. typing dot. which would be great for blind persons and screen readers as well, as well for small and large screens (4) list the languages there quickly accessible.

Aklapper renamed this task from vector skin, table and infobox overlap with each other to vector skin, table and infobox overlap with each other (when using "narrow and widescreen" gadget).Oct 15 2021, 6:47 AM
Aklapper closed this task as Invalid.