Page MenuHomePhabricator

Flaky Selenium test in importingFilters.js
Closed, DuplicatePublic

Description

[0-1] Error in "When importing a filter."before all" hook for "the interface should be visible""
Error: element ("#mw-abusefilter-switcheditor") still not clickable after 5000ms
    at ViewEditPage.switchEditor (/workspace/src/extensions/AbuseFilter/tests/selenium/pageobjects/viewedit.page.js:37:10)
    at Context.<anonymous> (/workspace/src/extensions/AbuseFilter/tests/selenium/specs/importingFilters.js:25:16)
[0-1] FAILED in chrome - /tests/selenium/specs/importingFilters.js

Seen in https://integration.wikimedia.org/ci/job/quibble-vendor-mysql-php72-selenium-docker/81677/console

Event Timeline

Maybe similar to T270176? Especially given the absence of recent changes to the AF repo. It doesn't help that there's no recorded video for this failure.

Maybe similar to T270176? Especially given the absence of recent changes to the AF repo. It doesn't help that there's no recorded video for this failure.

@zeljkofilipin do you know why there wouldn't be a recorded video for the failure?

@kostajh the only thing that comes to my mind is that the failure could be in a hook. At the moment, we record only tests, not hooks. Tracked as T285078: Record videos in hooks.

Looks like that's the problem, the failure is in a hook:

[0-1] Error in "When importing a filter."before all" hook for "the interface should be visible""

Looks like that's the problem, the failure is in a hook:

[0-1] Error in "When importing a filter."before all" hook for "the interface should be visible""

Ah, I didn't know about that task. Thanks!