Page MenuHomePhabricator

Add PHP 8.1 for PHP extensions CI
Closed, ResolvedPublic

Description

PHP 8.1 is GA now, it would be good to have it as part of CI for our PHP extensions (luasandbox, wikidiff2, etc.)

Event Timeline

Change 742827 had a related patch set uploaded (by Jforrester; author: Jforrester):

[integration/config@master] Zuul: Add PHP81 as experimental for PHP extensions etc.

https://gerrit.wikimedia.org/r/742827

Change 742827 merged by jenkins-bot:

[integration/config@master] Zuul: Add PHP81 as experimental for PHP extensions etc.

https://gerrit.wikimedia.org/r/742827

Mentioned in SAL (#wikimedia-releng) [2021-12-01T00:23:12Z] <James_F> Zuul: Add PHP81 as experimental for PHP extensions etc. T293509

Experimental job passes for wikidiff2 and luasandbox; should we just enable for all?

Change 743995 had a related patch set uploaded (by Jforrester; author: Jforrester):

[integration/config@master] Zuul: Add PHP81 as voting for libraries, PHP extensions etc.

https://gerrit.wikimedia.org/r/743995

Change 743995 merged by jenkins-bot:

[integration/config@master] Zuul: Add PHP81 as voting for libraries, PHP extensions etc.

https://gerrit.wikimedia.org/r/743995

Mentioned in SAL (#wikimedia-releng) [2022-04-28T20:31:25Z] <James_F> Zuul: Add PHP81 as voting for libraries, PHP extensions etc. for T293509