Page MenuHomePhabricator

Drop legacy installer script from CheckUser extension (update.php hooks should already exist)
Closed, ResolvedPublic

Description

Do we really need to reinvent the wheel?

Thought not.


Version: unspecified
Severity: enhancement

Details

Reference
bz27431

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 11:18 PM
bzimport added a project: CheckUser.
bzimport set Reference to bz27431.
bzimport added a subscriber: Unknown Object (MLST).
Reedy created this task.Feb 15 2011, 2:56 PM
AGK added a comment.Oct 31 2011, 11:58 PM

Because two seconds on Terminal are easier than five minutes peering at your Database Manager Of Choice's query window. Nobody likes messing around with the db more than can be helped, hence the handy install script. What's the big deal?

I think the OP is referring to the fact that it could use the Updater classes (and log the update as completed) via update.php.

(In reply to comment #1)

Because two seconds on Terminal are easier than five minutes peering at your
Database Manager Of Choice's query window. Nobody likes messing around with the
db more than can be helped, hence the handy install script. What's the big
deal?

That has nothing to do with it... Reedy is talking about why its rolling its own method instead of using the defacto standard that uses the update.php magic.

aaron added a comment.Nov 1 2011, 12:02 AM

At the time the script was written, I think update.php and friends sucked and didn't really support this stuff too well.

AGK added a comment.Nov 1 2011, 12:02 AM

(In reply to comment #3)

(In reply to comment #1)

Because two seconds on Terminal are easier than five minutes peering at your
Database Manager Of Choice's query window. Nobody likes messing around with the
db more than can be helped, hence the handy install script. What's the big
deal?

That has nothing to do with it... Reedy is talking about why its rolling its
own method instead of using the defacto standard that uses the update.php
magic.

Ah, I misunderstood. I thought his gripe was with that the extension makes the db changes with a script, rather than posting the query stuff on the MWwiki extension page - for pasting into a query window. I know a lot of people who run their own sites don't have shell access and have to find workarounds.

brion added a comment.Nov 1 2011, 12:06 AM

I've changed the summary to clarify that we probably want to kill off that installer script.

IIRC there *are* already updater hooks in which should take care of setup when maintenance/update.php is run.

Should check to confirm there's nothing else that installer does that's necessary and go ahead and drop it out and update documentation to indicate using the regular updater channels.

  • Bug 32456 has been marked as a duplicate of this bug. ***
Krenair added a subscriber: Krenair.Feb 7 2016, 1:16 AM

The installer script does things like importing from $wgCheckUserLog and importing recentchanges into cu_changes...

Restricted Application added subscribers: JEumerus, Aklapper. · View Herald TranscriptFeb 7 2016, 1:16 AM
Glaisher added a subscriber: Glaisher.

Open patches that need reviewing (in dependent order):

Change 307336 had a related patch set uploaded (by Glaisher):
Cleanup CheckUser setup and remove old files

https://gerrit.wikimedia.org/r/307336

Huji added a subscriber: Huji.Sep 2 2016, 6:23 PM

Excellent! I am very happy that someone has finally submitted a patch to do away with $wgCheckUserLog, among other things. I will try to review these in the next two weeks.

Change 307336 had a related patch set uploaded (by Glaisher):
Cleanup CheckUser setup and remove old files

https://gerrit.wikimedia.org/r/307336

Glaisher closed this task as Resolved.Sep 7 2016, 4:40 PM
Glaisher claimed this task.

Change 307336 merged by jenkins-bot:
Cleanup CheckUser setup and remove old files

https://gerrit.wikimedia.org/r/307336

Meno25 removed a subscriber: Meno25.Sep 17 2016, 5:41 PM
MarcoAurelio moved this task from Backlog to Closed on the CheckUser board.Jan 22 2017, 4:31 PM