Page MenuHomePhabricator

First-Run Experience: Pop-up appears behind page chrome when starting creating new talk page
Closed, ResolvedPublic

Description

Thank you to @Pelagic for reporting this issue: Topic:Wk7cqvino2vjv0jz.


This task is about fixing Automatic Topic Subscription's first-run experience such that the pop-up appears "in front of" the page's chrome when creating a new talk page.

Behavior

  1. Visit Special:Preferences to ensure the Automatically subscribe to topics setting is enabled
  2. Visit a talk page that does not yet exist. E.g. https://patchdemo.wmflabs.org/wikis/2f3d9efbec/w/index.php?title=Talk:Tea&action=edit&redlink=1 .
  3. Click the Start a discussion affordance
  4. Type some text into the New Discussion Tool's Title and Description fields

Actual

  1. ❗️Notice the You have subscribed pop-up appears is obfuscated by the page's chrome and menus
Legacy VectorNew Vector
Screen Shot 2021-11-17 at 6.03.39 PM.png (438×1 px, 109 KB)
Screen Shot 2021-11-17 at 6.08.23 PM.png (488×1 px, 107 KB)

Expected

  1. ✅Notice the You have subscribed pop-up appears atop/in front of the page's chrome and menus

Event Timeline

matmarex added a project: Editing QA.
matmarex added a subscriber: matmarex.

Oh, I've noticed this as well, and fixed it already before we merged the patch (but after I set up the last demo): https://gerrit.wikimedia.org/r/c/mediawiki/extensions/DiscussionTools/+/714438/15..16/modules/controller.js

The popup should be displayed below the new comment instead of above if there isn't space for it:

image.png (2×3 px, 378 KB)

(please test after T295945 is fixed, because the popup when creating new talk page is broken for an unrelated reason)

ppelberg claimed this task.