Page MenuHomePhabricator

Borders between countries are not always depicted in Wikimedia Maps
Open, HighPublicBUG REPORT

Description

List of steps to reproduce:

image.png (815×1 px, 376 KB)

What happens?:
Borders between some countries are not depicted in Wikimedia Maps inserted into Wikipedia pages using Extension:Kartographer. They become visible only if you zoom in enough, or, in case of Lithuanian-Latvian border, it is not visible even in the maximal zoom.

What should have happened instead?:
All state borders should have been shown

Software version, browser information, screenshots, other information, etc:
This bug appears across multiple devices:

  1. Windows 7, Google Chrome
  2. Windows 10, Opera
  3. Android, Opera

And in multiple projects:

  1. uk.wikipedia.orf
  2. en.wikipedia.org
  3. ua.wikimedia.org

Event Timeline

Jgiannelos closed this task as Resolved.EditedWed, Jan 5, 11:24 AM
Jgiannelos claimed this task.
Jgiannelos added a subscriber: Jgiannelos.

This looks like its fixed in current production.

For example

image.png (443×348 px, 83 KB)

Tohaomg triaged this task as High priority.

Borders between France and Belgium and between Belgium and the Netherlands were indeed fixed, but some missing borders were not fixed (like DR Congo-Angola), and also some borders that were there before, now disappeared (Lithuania-Belarus, Lithuania-Russia, Belarus-Russia, Belarus-Ukraine, Ukraine-Russia, Ukraine-Moldova).

Set this task at a high prority, because the map in its current state imposes great reputational risks for the Ukrainian Wikipedia, as Ukrainian-Russian border is a very sensitive political topic and this border being absent from the map can be seen as Wikipedia denouncing Ukrainian independence and sovereignity. We should expect media titles like "Wikipedia decided to restore the USSR" if this bug is not fixed ASAP, which would be a PR disaster for the Ukrainian Wikipedia.

image.png (720×960 px, 403 KB)

Aklapper raised the priority of this task from High to Needs Triage.Wed, Jan 5, 12:09 PM
MSantos triaged this task as High priority.Wed, Jan 5, 1:15 PM
MSantos added a subscriber: MSantos.

We're working on it at the moment. I'll keep the priority high, for now. We already have a fix to be applied and wrapping up investigations.

Wonderful, thank you. But I have to ask when should the fix be expected: is it hours, days or weeks? (our communicational team is pretty alerted right now)

@Tohaomg the fix should be up in a couple of hours but it might take a full day until tiles are refreshed, I'll keep you posted.

Update on the issue: Manually reloading the OSM data for specific regions looks like its working directly hitting kartotherian for maps:

image.png (1×2 px, 3 MB)

We still need to wait for upstream cache to expire for the changes to be reflected on maps.wikimedia.org.

It looks like upstream cache picked up the new borders we manually imported. cc @Tohaomg

For me at the moment Ukraine's and other former USSR republics national borders look fine now, but there are still some issues elsewhere:

Ukraine is missing some regional borders:

image.png (656×973 px, 406 KB)

(Cf this random map of Ukraine: https://commons.wikimedia.org/wiki/File:UkraineRegionalDomesticProductP2012change.PNG )

There is btw a separate issue there, the signage for Кривий ріг renders properly only since Zoom Level: 8, and this happens elsewhere on the map too, but probably a subject to a separate ticket

Still a big Angola, DRC, Uganda and Kenya conglomerate shown:

image.png (657×992 px, 279 KB)

Both Koreas and PRC are bundled too:

image.png (272×305 px, 68 KB)

India misses border with PRC too:

image.png (487×664 px, 238 KB)

Mali, (Western Sahara) and Morocco:

image.png (545×742 px, 147 KB)

I am not too good at geography so I would not be surprised if there are some things wrong elsewhere too.

Map data © OpenStreetMap contributors as per their licence.

Its not feasible to fix each case one by one so it looks like the best way forward is to run a full planet import.