Values from "Autocomplete from url=my_query" do not get bolded on user input
Closed, ResolvedPublic




In our project, we have got fields populated by a service using "Autocomplete from url=my_query" capabilities in Semantic Forms 2.x defined like this :

{{{fieldfield_nameautocomplete from url=field_query_namemandatory}}}

This work as needed, text is emphazed / grayed as well as I type letters but list isn't filtered and colored at all like in MediaWiki Search Engine.

Nevertheless, this works very well with built-in properties, categories, namespaces, etc.

Are you able to reproduce it ?

Many thanks for your answer.

Best regards,

Arnaud M.

Version: unspecified
Severity: normal


bzimport raised the priority of this task from to Normal.
bzimport set Reference to bz27702.
bzimport created this task.Feb 25 2011, 9:34 AM

Hi, sorry, what's the bug here? That autocompletion in SF looks different than autocompletion in the search box? wrote:

Good morning Yaron Koren,

First, I thank you for your reply.

In fact, in our installation, list isn't filtered while data matching to chars are bold. So, we have to scroll the list by hand to choose and select right value(s). Values which don't match are not removed from the list. Is this normal ?

Thanks for your help.

Best regards,


Aklapper removed Yaron_Koren as the assignee of this task.Sep 2 2015, 3:55 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 2 2015, 3:55 PM
Yaron_Koren renamed this task from List produced by Autocomplete from url=my_query to Values from "Autocomplete from url=my_query" do not get bolded on user input.Nov 19 2015, 7:20 PM
Yaron_Koren set Security to None.

@Rammanojpotla - I certainly admire your enthusiasm, but please don't take any more micro-tasks - I'm trying to limit every potential student to just one or two tasks.

Rammanojpotla removed Rammanojpotla as the assignee of this task.Feb 15 2018, 5:32 PM
Rammanojpotla added a subscriber: Rammanojpotla.

okay I am removing me as assigne

Bkybala9 added a subscriber: Bkybala9.EditedThu, Feb 22, 6:00 PM

A couple of helpful pointers here for GSOC students trying to solve this microTask. Since this task is old couple of things change slightly, just the nomenclature though, the idea and essence remain the same.

  1. SF or Semantic Forms 2.x here means Page Forms. Its the old name of Page Forms.
  1. Autocomplete from url is now values from url.

Ah, okay. Thank you @Bkybala9

ssaluja16 added a comment.EditedFri, Mar 2, 9:37 PM

So I have been working on the task but I have my midterms in the coming week so I won't be able to contribute till then, but will send the update as soon as I figure it out completely(I think I might just have gotten it, I need to verify).

ssaluja16 added a comment.EditedFri, Mar 16, 8:01 AM

So I have been unable to replicate the bug after trying for a week, and have hence been unable to solve the problem, I apologize.

ssaluja16 removed ssaluja16 as the assignee of this task.Fri, Mar 16, 1:45 PM
ssaluja16 added a subscriber: ssaluja16.
Yaron_Koren closed this task as Resolved.Fri, Mar 16, 2:59 PM
Yaron_Koren claimed this task.

@ssaluja16 - thank you for looking into this. I am marking this issue as "Resolved", based on your findings.

@Yaron_Koren ,thank you for the opportunity. Is there any other way I can contribute?

@ssaluja16 - yes, there are lots other ways to contribute. But you should know that I already selected another student as the one to do the GSoC Page Forms project (assuming the project gets selected). Sorry about that. So if you're looking to do a GSoC project, I suggest you find another one.