Page MenuHomePhabricator

Please add Version to ExtensionDependencyError
Open, Needs TriagePublic

Description

pymediawikidocker tries run a MediaWiki environment with different version of MediaWiki and is not prepared yet to handle different versions of extensions.

The CI of the tests shows the following error:

The content of stderr is 'Fatal error: Uncaught ExtensionDependencyError: PageForms is not compatible with the current MediaWiki core (version 1.31.14), it requires: >= 1.32.0.

Which PageForms version is incompatible? I had to go to the extension webpage to guess that this is for version 5.3.1 - Unfortunately this seems not to be semantic versioning compatible with composer. I selected ^5.2.1 and was wondering why i still get the error message. I am now forced to pin to 5.2.1 for the time being.

Event Timeline

Is this a problem with Page Forms, or Pymediawikidocker? (Or something else?) By the way, Page Forms dropped support for MW 1.31 in version 5.3.

The version of pages forms installed is incompatible with the installed mediawiki version

pymediawikidocker currently tries to use the same version of an extension accross all versions of MediaWiki. The version i intended to selected for this was 5.2.1 which actually works.
The composer syntax i used was "^5.2.1" which actually seems to select the version 5.3 for Mediawiki 1.31 which leads to an incompatibility.

The message which was displayed showed "Uncaught ExtensionDependencyError: PageForms is not compatible with the current MediaWiki core (version 1.31.14), it requires: >= 1.32.0."
My request is to change the message to "Uncaught ExtensionDependencyError: PageForms 5.3 is not compatible with the current MediaWiki core (version 1.31.14), it requires: >= 1.32.0." so that in similar future situations it would be easier to know which version of the extension is causing the situation.

Also i was wondering why the semantic versioning is not functioning in the expected way here. I was under the assumption that "^5.2.1" would only select compatible versions which for "5.3" doesn't seem to hold true.

That's too bad about the problems. I don't know if this is something that can be fixed in Page Forms... the "ExtensionDependencyError" message is not coming from Page Forms, but from somewhere else - presumably core MediaWiki. And I also don't know why "^5.2.1" would select 5.3.