Page MenuHomePhabricator

Defect: Block notice when editing talk page of blocked user doesn't go away after block expires
Closed, DeclinedPublic

Description

http://en.wikipedia.org/w/index.php?title=User_talk:76.217.100.52&action=edit has the this user (the anon, not the person editing) is blocked notice, even after the block expired. Expected behaviour is for the notice to only be present if user is blocked.

This feels like a dupe, but i can't find anything for it. I have a vague memory of their being an issue like this that seemed to only be present on enwikipedia (not sure though).

bug reported by Sven_Manguard on irc.


Version: unspecified
Severity: minor

Details

Reference
bz27858

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 11:33 PM
bzimport set Reference to bz27858.
bzimport added a subscriber: Unknown Object (MLST).
Bawolff created this task.Mar 5 2011, 12:24 AM
  • Bug 29020 has been marked as a duplicate of this bug. ***

Here's a currently blocked example page:
http://en.wikipedia.org/wiki/User_talk:76.22.193.206

There's a red box 'This user is currently blocked' bla bla, which gets shown on:

  • the user page
  • the user talk page
  • the user page, while editing
  • the user talk page, while editing

The edit view shouldn't be cached, so ought to update automatically after the block; the user page & user talk page views themselves however may still be cached after a block expires, so you'd still see the warning there after an expiry.

Can find more block samples here: http://en.wikipedia.org/w/index.php?title=Special:Log/block

Likely fix:

  • make sure the user page & user talk page get purged from cache when a block expires or is removed (this should actually fix it more or less correctly)

Clearing on expiration requires actually having some handler per-expiration; not sure offhand if the current expiries are just bulk deletes or give that chance.

I spent some time testing this and taking screen shots. I found a bunch of 1 week blocks that were about to expire and started watching them.

My guess, from this testing is that, while the times on the site all given in UTC+0, whatever handles expiration sees this as local time and runs the expiration in a different timezone.

I'm attaching two screenshots showing the problem. UTC time is show via a gadget in the upper right part of the webpage. EDT is shown by my local clock. I'll try a couple more spot checks to confirm this today, but it looks like the expiration is 6-7 hours off.

Created attachment 8591
An overdue block

Attached:

Created attachment 8592
same block 7 hours later after it had expired.

Attached:

Note, in the log excerpt, the time that the user was blocked at is localized to whatever timezone is set in your preferences. However the user is blocked message is displayed based on if the user is actually blocked. Its unclear if this bug is the result of people being confused by localizing the time in the log excerpt (/me personally has never liked how we only modify some timestamps for timezone), or if the message is being included after the block has actually expired.

I think this is a good issue to track down. Will try to find some more bugs about timezone so we can get some sanity about it.

(In reply to comment #6)

Note, in the log excerpt, the time that the user was blocked at is localized to
whatever timezone is set in your preferences.

You can see the local time in the upper right of the screenshots. But I'll test again after verifying that the preferences is correct. The preferences may have been off by an hour, but nothing like the 2-3 hours the screenshots show.

Re:

Resolve Fixed status change.

Who, what when where and how did this get fixed?

tagging bugs for Marcus to look at

Reopening since I've no clue why I closed it.

saper added a comment.Jun 21 2012, 1:55 PM

Can we check if this is still a problem after bug 5445 has been fixed?

TBolliger renamed this task from Block notice when editing talk page of blocked user doesn't go away after block expires to Defect: Block notice when editing talk page of blocked user doesn't go away after block expires.Jan 12 2018, 11:25 PM
TBolliger closed this task as Declined.
TBolliger added a subscriber: TBolliger.

No reports since 2011, closing. If this is reproduced again, please provide reproduction steps and links.