Page MenuHomePhabricator

HTML escaped when marking thread as read from Special:NewMessages
Closed, DeclinedPublic

Description

The thread's title, in wikitext, is:

[[MediaWiki:Config-using531]] PHP version compatible with MediaWiki, or MediaWiki compatible with PHP version ?

And everywhere it renders fine but when marking this thread as read it get's shown as:

<a href="/wiki/MediaWiki:Config-using531/en">MediaWiki:Config-using531/en</a> PHP version compatible with MediaWiki, or MediaWiki compatible with PHP version ?

See attachment.


Version: unspecified
Severity: major

Details

Reference
bz27921

Event Timeline

bzimport raised the priority of this task from to Lowest.Nov 21 2014, 11:24 PM
bzimport set Reference to bz27921.
bzimport added a subscriber: Unknown Object (MLST).
Krinkle created this task.Mar 7 2011, 7:25 PM
  • Bug 27934 has been marked as a duplicate of this bug. ***

Created attachment 8265
BugZilla ate it during bug creation submission, it does that quite often

Attached:

  • Bug 28294 has been marked as a duplicate of this bug. ***
He7d3r added a comment.Aug 6 2012, 1:24 AM

Created attachment 10938
No bugs here...

This seems to be fixed.

Attached:

Same here, re-opening.

This tests the ajax-submission, rather then the open-in-new-tab method that doesn't use interactive state.

meaning, this bug doesn't occur in the ajax-submission, but when submitting to a new tab

Qgil added a comment.Mar 21 2013, 5:54 AM

Do you mean right-clicking "Mark as read" and selecting to open it in a new tab, or how? I can't find a way to do this in test2 or mediawiki.org.

WORKSFORME?

Qgil added a comment.Feb 22 2014, 9:43 PM

No activity in almost one year. Marking as "Lowest" to reflect what seems to be the case. Feel free to correct.

Jorm removed a subscriber: Jorm.Dec 26 2015, 7:26 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 26 2015, 7:26 PM

LiquidThreads has been replaced by StructuredDiscussions on all Wikimedia production wikis (except one, which will be done soon). It is no longer under active development or maintenance, so I'm re-classifying all open LQT tasks as "Lowest" priority.

Qgil removed a subscriber: Qgil.Aug 8 2016, 8:10 AM
Krinkle closed this task as Declined.Mar 27 2017, 10:27 PM
Krinkle removed subscribers: Krinkle, wikibugs-l-list.