Page MenuHomePhabricator

"Marked as read"-message does not parse the title the same way "titles" are (blocks like <gallery> should not expand)
Closed, DeclinedPublic

Description

Title says it all, see next attachments.
(can't add it right away as BugZilla will eat it)


Version: unspecified
Severity: major
See Also:
T29921: HTML escaped when marking thread as read from Special:NewMessages

Details

Reference
bz28294

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 11:36 PM
bzimport set Reference to bz28294.
bzimport added a subscriber: Unknown Object (MLST).
Krinkle created this task.Mar 28 2011, 5:08 PM

Created attachment 8339
Before (good)

before I click the button we see the normal title as parsed correcly. <gallery> is not exanded.

Attached:

Created attachment 8340
After (bad)

After clicking the button, we see the "Marked as read" version, which screws it up.

Attached:

  • This bug has been marked as a duplicate of bug 27921 ***

Ops... It is not the same problem.

But the problems are likely on LiquidThreads/newmessages.js.

He7d3r added a comment.Aug 6 2012, 1:16 AM

Created attachment 10937
No bugs here...

I'm not able to reproduce this.

Attached:

Re-opening, you're not performing the same action as I did in the screenshot. The ajax-markAsRead is working fine. I'm testing the form POST fallback which is used for slow connections, broken script scenario's or large queues.

See the screenshot that I posted (attachment 8340).

Jorm removed a subscriber: Jorm.Dec 26 2015, 7:28 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 26 2015, 7:28 PM
Jdforrester-WMF lowered the priority of this task from Normal to Lowest.Aug 4 2016, 11:34 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

LiquidThreads has been replaced by StructuredDiscussions on all Wikimedia production wikis (except one, which will be done soon). It is no longer under active development or maintenance, so I'm re-classifying all open LQT tasks as "Lowest" priority.

Liuxinyu970226 removed a subscriber: wikibugs-l-list.
Krinkle closed this task as Declined.Mar 27 2017, 10:26 PM
Krinkle removed a subscriber: Krinkle.