Page MenuHomePhabricator

[EPIC] Make Wikibase work with Vue 3 (non-migration build)
Open, Needs TriagePublic

Description

This is the follow-up to T294465: Make Wikibase work with the Vue 3 migration build. While we are now using the migration build in production, we want to use pure Vue 3 at some point.

“Subprojects”:

For local testing, the MediaWiki core change to use pure Vue 3 may be useful.


Wikidata-related, but out of scope for this task, because not part of MediaWiki:

  • Mismatch Finder
  • Query Builder

Related Objects

Event Timeline

Change 773276 had a related patch set uploaded (by Lucas Werkmeister (WMDE); author: Lucas Werkmeister (WMDE)):

[mediawiki/extensions/WikibaseLexeme@master] WIP: Fully migrate to Vue 3

https://gerrit.wikimedia.org/r/773276

Change 792243 had a related patch set uploaded (by Michael Große; author: Michael Große):

[mediawiki/extensions/Wikibase@master] bridge: Vue3: add `compatConfig: { MODE: 3 }` to all components

https://gerrit.wikimedia.org/r/792243

Change 792243 merged by jenkins-bot:

[mediawiki/extensions/Wikibase@master] bridge: Vue3: add `compatConfig: { MODE: 3 }` to all components

https://gerrit.wikimedia.org/r/792243

ItamarWMDE renamed this task from Make Wikibase work with Vue 3 (non-migration build) to [EPIC] Make Wikibase work with Vue 3 (non-migration build).Oct 25 2022, 8:41 AM
ItamarWMDE moved this task from Incoming to Ongoing on the wmde-wikidata-tech board.
ItamarWMDE added a project: Wikidata Dev Team.
ItamarWMDE moved this task from Incoming to Epics+STALLED on the Wikidata Dev Team board.

Change 852893 had a related patch set uploaded (by Michael Große; author: Michael Große):

[mediawiki/extensions/WikibaseLexeme@master] Add `compatConfig: { MODE: 3 },` to all components

https://gerrit.wikimedia.org/r/852893

Change 773276 merged by jenkins-bot:

[mediawiki/extensions/WikibaseLexeme@master] Fully migrate to Vue 3

https://gerrit.wikimedia.org/r/773276

Change 852893 merged by jenkins-bot:

[mediawiki/extensions/WikibaseLexeme@master] Add `compatConfig: { MODE: 3 },` to all components

https://gerrit.wikimedia.org/r/852893

Change 853237 had a related patch set uploaded (by Lucas Werkmeister (WMDE); author: Lucas Werkmeister (WMDE)):

[mediawiki/extensions/WikibaseLexeme@master] Fix languageAndLexicalCategoryWidget whitespace for Vue 3

https://gerrit.wikimedia.org/r/853237

Change 853237 merged by jenkins-bot:

[mediawiki/extensions/WikibaseLexeme@master] Fix languageAndLexicalCategoryWidget whitespace for Vue 3

https://gerrit.wikimedia.org/r/853237

@Catrope With the next train, the last pieces of the Wikibase Vue 3 migration should be rolling out, and we're done migrating the all the Wikibase Vue production code on MediaWiki.

Also in this graph of tasks I can see T300176: Make Termbox SSR and CSR match exactly, but that is not directly related to the Vue 3 migration, I think, merely discovered during it.

As for non-production code, I can see two open tasks:

@Catrope With the next train, the last pieces of the Wikibase Vue 3 migration should be rolling out, and we're done migrating the all the Wikibase Vue production code on MediaWiki.

Thank you so much!

Also in this graph of tasks I can see T300176: Make Termbox SSR and CSR match exactly, but that is not directly related to the Vue 3 migration, I think, merely discovered during it.

I agree

As for non-production code, I can see two open tasks:

All references to "vue" in package.json files in the Wikibase repo are to 3.x, none to 2.x, so I think this is done.

It's not blocking, but it would be nice to find a solution. I'll take a look at this again soon.