Page MenuHomePhabricator

Developer Hub homepage
Closed, ResolvedPublic

Description

The Developer Hub prototype requires a prototype homepage.

It's at http://devhub.wmflabs.org/wiki/Dev:Data_and_developer_hub with the Blueprint skin.

Details

Reference
fl484

Related Objects

StatusAssignedTask
ResolvedVolker_E
ResolvedNone
DeclinedNone
DeclinedNone
ResolvedQgil
ResolvedQgil
ResolvedQgil
Resolved Spage
Resolved Spage
Resolved Spage
DeclinedQgil
Resolved Spage
Resolved Spage
OpenNone
DeclinedNone
ResolvedPrtksxna
ResolvedPrtksxna
ResolvedPrtksxna
Resolved Spage
ResolvedJdlrobson
ResolvedNone
DeclinedNone
ResolvedNone
ResolvedQgil
ResolvedVolker_E
Resolved violetto
ResolvedVolker_E
ResolvedVolker_E
DeclinedNone
ResolvedNone
ResolvedVolker_E
DeclinedNone
ResolvedVolker_E
ResolvedVolker_E
ResolvedVolker_E
ResolvedVolker_E
ResolvedPastakhov
ResolvedNone
ResolvedPastakhov
ResolvedNone
ResolvedVolker_E
ResolvedNone
ResolvedVolker_E
ResolvedVolker_E
ResolvedVolker_E
OpenNone
Resolved Spage
Resolved Spage
Resolved Spage
OpenNone
ResolvedNone
OpenNone
ResolvedAnomie
OpenNone
OpenNone
OpenNone
Resolved Spage
Resolvedori
OpenNone
Resolvedjeropbrenda
OpenNone
Resolved Spage

Event Timeline

flimport raised the priority of this task from to Normal.Sep 12 2014, 1:43 AM
flimport added a project: Web-APIs-Hub.
flimport set Reference to fl484.
Qgil lowered the priority of this task from Normal to Low.Oct 22 2014, 6:20 PM
Spage added a subscriber: Spage.

For February, I will write initial Showcase/Inspire articles on mediawiki.org, do some polishing of the APIs they use (T306), and have basic "sandbox" functionality via "click this link to see API results". Those will be enough to present developer hub homepage similar to the wireframes on mw.org.

I'll probably put the page in the API: namespace.

For March we'll explore/prototype other features of the developer hub: dedicated namespace (T369), custom skin (T301: Define the look&feel of the Developer Hub), special API sandbox code, etc.

Spage claimed this task.Feb 3 2015, 9:38 AM
Spage raised the priority of this task from Low to High.
Spage set Security to None.
Spage moved this task from Backlog to Doing on the ECT-March-2015 board.Mar 3 2015, 4:50 AM
Qgil added a comment.Mar 3 2015, 6:52 AM

Thanks!

"Back to How to contribute" assumes that you come from there, which is perhaps a too big assumption.

In fact, we need to think about users landing in this homepage first, without having seen anything else of mediawiki.org. I would add a section at the end including a link to the Developer Hub for developers of MediaWiki, the 2-3 most important pages related to Documentation, and How to Contribute (not necessarily in this order).

In T305#1081196, @Qgil wrote:

"Back to How to contribute" assumes that you come from there, which is perhaps a too big assumption.

Yup, rephrased.

In fact, we need to think about users landing in this homepage first, without having seen anything else of mediawiki.org.

I added an introductory sentence.

I would add a section at the end including a link to the Developer Hub for developers of MediaWiki, the 2-3 most important pages related to Documentation, and How to Contribute (not necessarily in this order).

If someone arrived here without having seen anything else, How to contribute can't be beat as a link back out, and I'm leery of offering any other links. Either developers are inspired to read more and explore or the page failed. (Of course if and when dev pages have their own skin we can guide users with top- and left-nav like, e.g. dev.mozilla.org.)

Qgil updated the task description. (Show Details)Mar 17 2015, 8:13 AM
Qgil added a comment.Mar 17 2015, 10:12 AM

I think the current homepage (and plan in general, probably) reflects that we are focusing on the developers (contributors) we already have around. In fact, dev.wikimedia.org needs to be efficient to the big majority of developers that we still don't have around. Most of them will not be "contributors", but "selfish" developers needing something and leaving with it... until the next time they need something else. I'm proposing T92941: Define personas for dev.wikimedia.org to solve this problem of lack of an agreed audience beyond "users of our APIs".

A consequence of the above is that we are not explaining what Wikimedia can offer to developers, because this is kind of obvious when you are already a tech contributor. However, this needs to be explained to all the new developers. Let's solve this part of the homepage in T92945: Reflect in dev.wikimedia.org what Wikimedia offers to developers.

When these two tasks are clear, then the homepage will be clearer and sharper as well. Inspire looks good and I can't wait to see more items listed. I would focus on title and image only, no description. The upper part of the homepage should be very visual, betting on bigger images and less text. Explore is good. Build needs work.

"There are many other ways to contribute" can be fine tuned once we have defined T92945 and when we work on the actual look & feel of the homepage (T301).

Another problem that is becoming more apparent is the navigation. How to walk through the hub finding what you need but not ending up swamped in semi-random destinations in mediawiki.org? But this has other important implications, and I will bring the discussion to T312. Let's forget about the navigation here.

Spage moved this task from Backlog to For review on the Web-APIs-Hub board.Mar 23 2015, 10:53 PM
Qgil added a comment.Mar 25 2015, 8:57 AM

Now we have an intro with pure text in the homepage. I think it would be good to give a clear visual cue to our readers about the types of content found. The text mentions text, media, and data, and we could use one icon for each, since there are plenty of icons to chose from with the paradigms "doc", "media", "database".

In fact, Wikifont provides two reusable icons already:
https://www.mediawiki.org/wiki/File:Article_icon.svg
https://www.mediawiki.org/wiki/File:PhotoGallery.svg

... and this one looks like a good candidate for the third.
https://www.mediawiki.org/wiki/File:PhotoGallery.svg

Good enough for a prototype, I would say.

This task was part of ECT-March-2015, and it is still open and assigned. Assuming that it belongs to ECT-April-2015 as well. Otherwise please edit accordingly.

Spage updated the task description. (Show Details)Jun 2 2015, 10:30 AM
Spage added a project: ECT-June-2015.
Spage moved this task from Backlog to Ready to Go on the ECT-June-2015 board.Jun 16 2015, 4:07 PM
Spage moved this task from Ready to Go to Doing on the ECT-June-2015 board.Jun 16 2015, 4:11 PM
Dzahn removed a subscriber: Dzahn.Jun 16 2015, 4:54 PM
In T305#1147949, @Qgil wrote:

... The text mentions text, media, and data, and we could use one icon for each, since there are plenty of icons to chose from with the paradigms "doc", "media", "database"
... and this one looks like a good candidate for the third.
https://www.mediawiki.org/wiki/File:PhotoGallery.svg

That's the same icon as for media, copy-paste error? I used File:Keyboard_switch.svg for data.

It's up at http://devhub.wmflabs.org/wiki/API:Data_and_developer_hub.

I also

  • added the Web API plug icon to the Blueprint titlebar
  • replaced "DEVWIKI" in the Blueprint titlebar with "Data and developer hub"
  • made images link to articles not their File: pages
  • the images on the home page link to the articles instead of File: pages

Definition of done? :-)

Qgil added a comment.Jun 19 2015, 8:36 AM

Good!

I made some more edits to reflect what I had in mind with the use of icons and polish the text of the main section of the homepage.

We don't need the page title in the homepage ("API:Data and developer hub"), and we will apply the kind of tricks that almost every single MediaWiki instance has to use, see https://www.mediawiki.org/wiki/Manual:FAQ#How_do_I_hide_the_main_page_title.3F

After this, I think we can resolve this task. Not that I think the homepage is spectacular, but at least reflects what two non-designers were after in this prototype. :)

Spage added a comment.EditedJun 23 2015, 9:51 AM
In T305#1381541, @Qgil wrote:

I made some more edits to reflect what I had in mind with the use of icons and polish the text of the main section of the homepage.

Compare Qgil's revision with previous. IMO the big icons overpower the "Inspire" screenshots below, we'll see.
BTW, any edits made on devhub are blown away when I Special:Import from mw.org, so I manually recreated those edits on mw.org (while waiting for DWVS, distributed wiki version system :-) ).

We don't need the page title in the homepage ("API:Data and developer hub")

That was a killer, exposing bugs T103454: Blueprint skin crashes in Title::equals() if you blank the title and T103488: Blueprint sidebar nav shows CSS if you use {{DISPLAYTITLE}}. I have patches for both. I earlier

  • made the home page on devhub be the Data and developer hub rather than the explanatory http://devhub.wmflabs.org/wiki/Main_Page
  • hid the {{Dev-Article-Badge}} on devhub, made it show a
  • added a beautiful (?) what's this help indicator in its place that doesn't work in the Blueprint skin.

After this, I think we can resolve this task. Not that I think the homepage is spectacular, but at least reflects what two non-designers were after in this prototype. :)

Remaining bugs/good ideas (also see T103986: issues with Data and Developer Hub prototype (tracking))

  • use the Dev: namespace instead of API: ASAP to avoid glitches when we implement on mw.org
  • lock devhub for editing, since the content comes from mediawiki.org (ask @Spage if you want editing rights, or if you want a page imported)
  • remove the blank space in the sidebar (probably where a "Discussion" link is intended, since Living style guide has it there)
    • Note the devhub talk pages redirect users to discuss on the equivalent page on mw.org, so adding a Discussion link would be indirect and confusing,
In T305#1391731, @Spage wrote:

while waiting for DWVS, distributed wiki version system :-)

In case you haven't already, you might enjoy reading this: https://en.wikipedia.org/wiki/User:HaeB/Timeline_of_distributed_Wikipedia_proposals

Change 220498 had a related patch set uploaded (by Dzahn):
misc-web: delete Varnish config for dev.wikimedia

https://gerrit.wikimedia.org/r/220498

Change 220504 had a related patch set uploaded (by Dzahn):
dev.wikimedia.org: delete puppet module

https://gerrit.wikimedia.org/r/220504

Change 220498 merged by Dzahn:
misc-web: delete Varnish config for dev.wikimedia

https://gerrit.wikimedia.org/r/220498

Change 220504 merged by Dzahn:
dev.wikimedia.org: delete puppet module

https://gerrit.wikimedia.org/r/220504

Spage moved this task from Backlog to Ready to Go on the ECT-July-2015 board.Jul 7 2015, 5:19 PM
Spage closed this task as Resolved.Jul 28 2015, 5:23 AM

We've had this at http://devhub.wmflabs.org more or less as intended for a while.