Page MenuHomePhabricator

Vector 2022 on Wikivoyage: sandbox in the user menu or not?
Closed, InvalidPublicBUG REPORT

Assigned To
None
Authored By
Patafisik
Jun 21 2022, 12:45 PM

Description

List of steps to reproduce (step by step, including full links if applicable):

  • log in, and select the skin Vector 2022
  • go to fr.wikivoyage
  • search the link to the sandbox
  • go to en.wikivoyage
  • search the link to the sandbox
  • go to it.wikivoyage
  • search the link to the sandbox
  • log out and go to it.wikivoyage
  • search the link to the sandbox

What happens?:

  • on fr.wikivoyage or en.wikivoyage, I can't find the link to the sandbox neither in the user menu nor in the sidebar
  • on it.wikivoyage, the link to the sandbox is on the sidebar, for users logged-in and logged-out

What should have happened instead?:

  • to improve consistency, you should consider to ask to communities why and eventually to show the sandbox on the user menu, for all the language versions of wikivoyage, and only for logged-in users, like in other sister projects.

Software version (if not a Wikimedia wiki), browser information, screenshots, other information, etc.:

Screenshot 2022-06-21 at 14-37-20 Wikivoyage – Informazioni di viaggio gratuite dal mondo.png (996×1 px, 1 MB)

Screenshot 2022-06-21 at 14-32-27 Wikivoyage – The free worldwide travel guide that you can edit.png (1×2 px, 1 MB)

Screenshot 2022-06-21 at 14-32-35 Wikivoyage – The free worldwide travel guide that you can edit.png (1×2 px, 1 MB)

Screenshot 2022-06-21 at 14-24-44 Algeria sahariana — Wikivoyage.png (649×1 px, 406 KB)

Screenshot 2022-06-21 at 14-24-19 Sahara algérien — Wikivoyage le guide de voyage et de tourisme collaboratif gratuit.png (649×1 px, 375 KB)

Screenshot 2022-06-21 at 14-23-51 Sahara algérien — Wikivoyage le guide de voyage et de tourisme collaboratif gratuit.png (649×1 px, 374 KB)

Screenshot 2022-06-21 at 14-24-50 Algeria sahariana — Wikivoyage.png (649×1 px, 405 KB)

Event Timeline

Aklapper closed this task as Invalid.EditedJun 24 2022, 10:08 AM

Hi, that's because https://it.wikivoyage.org/wiki/MediaWiki:Gadgets-definition defines a gadget MediaWiki:Gadget-Sandbox.js. This is unrelated to Desktop Improvements. :) If the Sandbox extension is installed, it is within the user menu and it is not in the sidebar.

Hi @Aklapper, if I understand well, by default the Sandbox on it.wikivoyage is on the sidebar, and only with the extension it is within the user menu, right? So the majority of users will see it on the sidebar. Also logged-out users, who don't need a sandbox. What is the project to point out this issue, in your opinion? Directly to it.wikivoyage?

Hi @Patafisik, user scripts, gadgets, templates, custom CSS are local on-wiki content. Local content is managed independently on each wiki, by each wiki community themselves. This needs fixing on the local wiki, indeed.