Page MenuHomePhabricator

[SUGGESTION] Expose group memberships for query through OpenID teams extension
Open, LowestPublic

Description

Many uses for having an OpenID provider on your wiki are to provide an authentication source that can be used for other sites.

Often these may apply only to a subset of users, for which user groups are usually a pretty good way to handle it. A foreign site could, for instance, limit authentication to users on a given site in a given group.

Using the OpenID Teams extension, the relying party can ask whether that group membership is valid at auth time, and get (at least part of) the list of available groups back.

I implemented the relying party side for StatusNet's OpenID plugin a while back for integration with LaunchPad which uses this extension; it shouldn't be too hard in theory to stick in on the provider side here.


Version: unspecified
Severity: normal
URL: https://dev.launchpad.net/OpenIDTeams

Details

Reference
bz29254

Related Objects

StatusAssignedTask
OpenNone
DeclinedWikinaut
OpenNone
Resolvedbrion
ResolvedNone
ResolvedNone
ResolvedParent5446
ResolvedNone
ResolvedWikinaut
OpenNone
ResolvedNone
ResolvedWikinaut
ResolvedWikinaut
OpenNone
OpenNone
ResolvedWikinaut
ResolvedWikinaut
ResolvedWikinaut
DeclinedWikinaut
DeclinedWikinaut
OpenNone
ResolvedWikinaut
InvalidWikinaut
InvalidWikinaut
ResolvedWikinaut
OpenNone
OpenNone
ResolvedTgr
ResolvedAnomie
ResolvedJoe
ResolvedJoe
Resolvedhashar
Resolved bd808
ResolvedAnomie
ResolvedKrinkle
OpenNone
ResolvedJanZerebecki
ResolvedKrinkle
ResolvedTgr
ResolvedWikinaut
ResolvedWikinaut
ResolvedWikinaut
OpenNone
OpenNone
ResolvedWikinaut
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
ResolvedWikinaut

Event Timeline

bzimport raised the priority of this task from to Lowest.Nov 21 2014, 11:38 PM
bzimport set Reference to bz29254.
brion created this task.Jun 2 2011, 9:31 PM

Yes, it will be resolved later (when other code issues are finally solved)

[Removing RESOLVED LATER as discussed in
http://lists.wikimedia.org/pipermail/wikitech-l/2012-November/064240.html .
Reopening and setting priority to "Lowest".
For future reference, please use either RESOLVED WONTFIX (for issues that will
not be fixed), or simply set lowest priority. Thanks a lot!]

@ Brion

Brion, you as the reporter, do you still really need this ?

Currently, I cannot implement this due to lack of time and in the view of more important other issues. Please allow me to close this as Resolved Wontfix, but please reopen, if you need it. In this case, perhaps you can then add some new related thoughts, and ideas, suggestion for implementation.

T. Gries: If you are not *against* fixing this for technical etc. reasons (that's the meaning of WONTFIX), it would be better to keep it open and lowest priority.

(In reply to comment #4)

T. Gries: If you are not *against* fixing this for technical etc. reasons
(that's the meaning of WONTFIX), it would be better to keep it open and
lowest
priority.

I am *against* fixing this.

I would very much like this. It doesn't necessarily need to be you that fixes it. Keeping it open allows other people to see it and pick it up if they want to tackle it.

(In reply to comment #6)

I would very much like this. It doesn't necessarily need to be you that fixes
it. Keeping it open allows other people to see it and pick it up if they want
to tackle it.

Very appreciated message, confirmed and accepted.

Aklapper removed Wikinaut as the assignee of this task.Jun 18 2015, 2:08 PM
Aklapper added a subscriber: Aklapper.

[Resetting task assignee to avoid cookie-licking. Please reclaim the task when you plan to actively work on this task. Thanks!]