Page MenuHomePhabricator

Display of special properties in Special:Properties page is strange (1.8 beta2)
Closed, ResolvedPublic

Description

There are two strange things about how special properties currently appear in the Special:Properties page, as you can see here:

http://discoursedb.org/wiki/Special:Properties

First, the special properties all show up at the beginning of the list, instead of mixed in with the rest; and second, some of them show up as having type "Special:Types/".


Version: unspecified
Severity: normal
URL: http://semantic-mediawiki.org/wiki/Special:Properties

Details

Reference
bz29422

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 21 2014, 11:36 PM
bzimport set Reference to bz29422.

Half of the bug is fixed in r106430.

Is this still a bug?

Hi - yes, definitely. Actually, in some ways I think it's stranger than it was before. Here are the issues I see:

  • The special properties all still show up at the beginning, instead of being sorted alphabetically with the rest.
  • The standard display of each line now reads "9 of type Has color (String)". That doesn't make any sense to me. 9 of what - values? That conflicts with the header, which reads, "The following properties are used in the wiki." It should be a listing of properties, not property values. And calling "Has color" a type is confusing, because "String" is a type.
  • Special properties defined by Semantic Forms and Semantic Drilldown are listed differently, for some reason - they show up as "Covers property (29)".
  • The SF special properties "Has default form" and "Has alternate form" don't show up at all.

(In reply to comment #3)

Hi - yes, definitely. Actually, in some ways I think it's stranger than it was
before.

Compare bug 41480.

(In reply to comment #3)

Try applying https://gerrit.wikimedia.org/r/#/c/31024/ and comment there if anything is still not functional. The first two problems you mentioned should definitely be fixed.

Ah! I just applied the change. I was really worried that the new wording represented a deliberate change, but now I realize that it was just text being displayed in the wrong order. (Which I should have figured out before.) The other issues are still there, though - including special properties showing up before the rest. (Though you could argue that that's a feature, not a bug.)

The special properties don't show before the rest for me. I tested this with both the stores, maybe someone else could also confirm this.

  • Bug 41480 has been marked as a duplicate of this bug. ***

elindarie wrote:

At htt://subnet.referata.com/wiki/Special:Properties (where "subnet" is something else), none of the Properties I entered with Special:CreateProperty show up, although I can list them one by one, e.g., http://subnet.referata.com/wiki/Property:Blahblah

When I visit http://subnet.referata.com/wiki/Property:Blahblah, I get

A database query error has occurred. This may indicate a bug in the software.

Query:
INSERT INTO `site_settings` (name,namespace,language_code,hours_timezone_offset,use_american_dates,use_24_hour_time,show_page_counters,use_subpages,allow_external_images,allow_lowercase_page_names,copyright_text,copyright_url,url_alias,use_liquid_threads,use_wysiwyg_editor,default_skin,background_color,sidebar_color,sidebar_border_color,logo_file,favicon_file,viewing_policy_id,registration_policy_id,editing_policy_id,questy_captcha_question,questy_captcha_answer,id,url,owner_id,db_name,created_at,service_level,delete_this,virtual_domain,custom_skin,google_analytics_id,google_verification_id,google_adsense_id,google_ad_slot,show_infobox,hide_main_edit_tab,rename_edit_tabs,use_drilldown_tag_cloud,tabs_for_categories) VALUES ('Referata','Referata','en','0','1','','1','','','','Creative Commons CC-BY-SA 3 license','http://creativecommons.org/licenses/by-sa/3.0/us/',NULL,'','','vector',NULL,NULL,NULL,NULL,NULL,'1','1','2',NULL,NULL,NULL,NULL,NULL,NULL,NULL,'basic','',NULL,NULL,NULL,NULL,NULL,NULL,'','','','','')
Function: DatabaseBase::insert
Error: 1048 Column 'url' cannot be null (localhost)

Jeroen - sorry about that; that's a weird error message Referata currently displays when the subdomain doesn't exist. ("subnet" is not the real subdomain for elindarie's wiki, according to their post.)

Anyway, the whole thing is irrelevant because Referata is not using the latest version of SMW. Plus, the issue they're talking about is unrelated to the issue I reported.

But since we're on the subject, elindarie - it could be that the properties you created are only to be found in the page Special:UnusedProperties, until you use them.

elindarie wrote:

Yes, you're right about the properties showing up in Special:UnusedProperties - I hadn't added any data yet. Thank you!

Another thing, maybe related, is that at

http://scratchpad.referata.com/wiki/Special:Properties

it doesn't show all the properties. There are probably over a thousand, but only 47 are shown. Is this fixed in later versions of SMW?

mwjames closed this task as Resolved.Nov 26 2014, 9:10 PM
mwjames added a subscriber: mwjames.

Anyway, the whole thing is irrelevant because Referata is not using the latest version of SMW.

Given the above comments, closing this issue.