Page MenuHomePhabricator

IP Info Help popups aren't fully opaque
Closed, ResolvedPublic2 Estimated Story PointsBUG REPORT

Description

See https://en.wikipedia.beta.wmflabs.org/wiki/Special:Contributions/192.252.212.12

Screen Shot 2022-09-23 at 5.07.52 PM.png (490×1 px, 88 KB)

AC:

  • Help popups should be fully opaque

Testing notes:

  • This should be testable on beta
  • To test:
    • Click on any of the tooltips in an IPInfo infobox (e.g. see screenshot above)
    • The tooltip that appears should now be opaque (unlike the screenshot)

Event Timeline

Tchanders set the point value for this task to 2.Oct 11 2022, 5:34 PM

Change 841959 had a related patch set uploaded (by AGueyte; author: AGueyte):

[mediawiki/extensions/IPInfo@master] Fix IPInfo Help popup opacity

https://gerrit.wikimedia.org/r/841959

Change 841959 merged by jenkins-bot:

[mediawiki/extensions/IPInfo@master] Fix IPInfo Help popup opacity

https://gerrit.wikimedia.org/r/841959

@Tchanders Looks like the IPInfo popups are now opaque as seen in the screenshot. I did notice something on IE since the format is different though. I'm not sure if you want that as a separate task, leave it on the same task, or if it's not an issue.

Test Environment: Beta

Chrome, Firefox, Microsoft Edge

T318405_IPInfo_PopupdOpaque_Chrome.png (1×3 px, 296 KB)

Internet Explorer

T318405_IPInfo_PopupdOpaque_IE.png (1×2 px, 146 KB)

@Tchanders Looks like the IPInfo popups are now opaque as seen in the screenshot. I did notice something on IE since the format is different though. I'm not sure if you want that as a separate task, leave it on the same task, or if it's not an issue.

Test Environment: Beta

Chrome, Firefox, Microsoft Edge

T318405_IPInfo_PopupdOpaque_Chrome.png (1×3 px, 296 KB)

Internet Explorer

T318405_IPInfo_PopupdOpaque_IE.png (1×2 px, 146 KB)

This looks like it's too do with the skin, probably existing before this patch. (It's difficult to see how this patch could have affected this part of the layout.)

Could you confirm whether Special:Contributions displays like this in IE for a user who doesn't have IPInfo? If so, it's not an issue with IPInfo. Otherwise we may need to file a separate task.

@Tchanders I'm not sure what happened but IE seems to be normal now as seen in the screenshot. I did notice the point in IE is lighter grey from the info box compared to Chrome in which the point color is consistent.

Chrome

T318405_IPInfo_PopupdOpaque_Chrome_Point.png (827×1 px, 210 KB)

IE

T318405_IPInfo_PopupdOpaque_IE_Point.png (895×1 px, 174 KB)

Thanks @GMikesell-WMF. I think that's likely to be an upstream bug in the component library, so feel free to move this to Done if that is the only outstanding problem.

@Esanders Is the issue with the popup worth filing?

@Tchanders Ok sounds good! I will move this to Done since that was the only problem I came across. Thank you so much once again!

@Esanders Is the issue with the popup worth filing?

Given that it's a minor issue only affect IE, probably not. IE usage is very low and Grade A support will be dropped soon-ish.