Page MenuHomePhabricator

Search and replace doesn't work on chrome or epiphany
Closed, InvalidPublic

Description

Search and replace doesn't find the text...

If you go to the provided url and open the 'Search and replace' feature from the advanced section of the enhanced toolbar, and try to find something simple as 'sujeitos', which is in the end of the page, the tool:

  • Doesn't find anything;
  • Doesn't provide any feedback to the user;
  • Doesn't cause any errors in the error console;

What is wrong with it? This bug makes it useless... =(


Version: unspecified
Severity: normal
URL: https://pt.wikipedia.org/w/index.php?title=Talco&oldid=26129559&action=edit&debug=1&uselang=en

Attached:

Details

Reference
bz30162

Event Timeline

bzimport raised the priority of this task from to Normal.
bzimport set Reference to bz30162.
bzimport added a subscriber: Unknown Object (MLST).
He7d3r created this task.Aug 1 2011, 1:54 PM
He7d3r added a comment.Aug 1 2011, 1:54 PM

Created attachment 8861
...but the text IS THERE!!!

Attached:

He7d3r added a comment.Aug 1 2011, 2:08 PM

Created attachment 8862
On Epiphany, something happens, but not what is expected

In the tests above I was not logged in (so gadgets/user scripts are not the cause), and was using Google Chrome 12.0.742.124, on Debian.

I was able to reproduce the problem also on Mozilla/5.0 (X11; U; Linux x86_64; pt-BR; rv:1.9.1.16) Gecko/20110701 Iceweasel/3.5.16 (like Firefox/3.5.16)

On Epiphany 2.30.6, the situation is a little better, but just a little: when I click on [Find next], the scrollbar moves to some random point (see screenshot) some lines after the one where the word is, and we still doesn't have any good indication of whether the text was found or not (no text message, no text selected on edit box), just the random scroolling.

On the other hand, if I click on "Replace all", I get "1 replacement(s) made." on all three browsers.

Attached:

He7d3r added a comment.Aug 1 2011, 5:45 PM

(In reply to comment #2)

In the tests above I was not logged in (so gadgets/user scripts are not the
cause), and was using Google Chrome 12.0.742.124, on Debian.

The problem also happens if I try Google Chrome 12.0.742.122 on Windows XP Professional.

On the other hand, it works fine on Firefox 4 and on IE 8, using Windows XP Professional.

  • This bug has been marked as a duplicate of bug 23509 ***

(In reply to comment #4)

  • This bug has been marked as a duplicate of bug 23509 ***

Aren't these different issues?
Should I copy the details from this bug to the other?

He7d3r added a comment.EditedMay 5 2012, 6:23 PM

These bugs doesn't seems to be related (and I just marked T25509: "Search and replace" should work in all supported browsers as a duplicate of T33780: WikiEditor dialogs kill the undo buffer).

TheDJ added a subscriber: TheDJ.Nov 17 2018, 2:11 PM

@He7d3r these browsers are no longer supported are they ? I suspect most of these issues have been fixed through the years, either by actual fixes, or by excluding the browsers in question from those that are elegible for JS execution.

I'm closing this ticket and if more specific issues are known, they should be filed separately and I might be able to take another look.

TheDJ closed this task as Invalid.Nov 17 2018, 2:11 PM