redirects to a page not updated after move
Open, LowPublic

Description

After a page move all redirects which a linking to the moved page have to be updated to the new target.

The problem is only visible with $wgMaxRedirects > 1, because than there a working redirects pointing to the page which are not updated after move and so the redirection is not working proper.

The update of the redirect table is missing.

Thanks.

Steps to reproduce:

  • set $wgMaxRedirects = 2;
  • create page A with text
  • move page A to page B with a redirect
  • move page B to page C with a redirect
  • visited page A, you get redirect to page B, not to page C
  • create page A2 with a redirect to page B (copy the wikitext from page A)
  • visited page A2, you get redirect to page C

Version: 1.20.x
Severity: normal

bzimport added a subscriber: Unknown Object (MLST).
bzimport set Reference to bz30359.

This is one of the reasons why I thought allowing multiple redirects was a bad idea.

However, we should NOT update the redirect table such that A->C, because that will break things if B is edited to be a redirect to D. Instead, the redirect table should continue saying A->B and B->C, and the redirect resolution code should follow both redirects rather than stopping after the first one.

  • Bug 33520 has been marked as a duplicate of this bug. ***

Was wondering - when double redirects are allowed, will there also be "triple redirects", "quadruple redirects" and so on? And will they also be allowed and functional?

Was wondering - when double redirects are allowed, will there also be "triple redirects", "quadruple redirects" and so on? And will they also be allowed and functional?

It depends just on the $wgMaxRedirects setting for the given wikisite. If it is set to 4, then a chain A->B->C->D->E will be transparent to the reader, but upon visiting A for the chain A->B->C->D->E->F you will see

E

(Redirected from A)
→F

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 2 2016, 3:19 PM
Restricted Application added subscribers: JEumerus, Matanya. · View Herald TranscriptJan 3 2016, 7:27 PM
Mdann52 claimed this task.Jan 3 2016, 7:27 PM
Mdann52 closed this task as a duplicate of T67064: Increase $wgMaxRedirects on enwiki.
JEumerus removed a subscriber: JEumerus.Jan 3 2016, 7:39 PM
Catrope removed a subscriber: Catrope.Jan 15 2016, 10:57 PM
petr.matas reopened this task as "Open".
petr.matas set Security to None.

This task cannot be a duplicate of T67064, because the bug described here is not mentioned there.

Add Comment