Page MenuHomePhabricator

Fatal error: Declaration of UserProtectPermissionManager::userCan must be compatible with MediaWiki\Permissions\PermissionManager::userCan
Open, Needs TriagePublicBUG REPORT

Description

Steps to replicate the issue (include links if applicable):

  • Enable the UserProtect extension in LocalSettings.php

What happens?:

Fatal error: Declaration of UserProtectPermissionManager::userCan($action, User $user, MediaWiki\Linker\LinkTarget $page, $rigor = self::RIGOR_SECURE) must be compatible with MediaWiki\Permissions\PermissionManager::userCan($action, User $user, MediaWiki\Linker\LinkTarget $page, $rigor = self::RIGOR_SECURE): bool in mediawiki\extensions\UserProtect\includes\UserProtectPermissionManager.php on line 40

Software version (skip for WMF-hosted wikis like Wikipedia):