Page MenuHomePhabricator

RTL display is broken with ?debug=true
Closed, ResolvedPublic

Description

Right-to-left style is only partially applied in debug mode.

From IRC:

aharoni if i try to use ?debug=true, right-to-left style is only partially applied to the page.
RoanKattouw Yes
RoanKattouw That's because Krinkle and TrevorParscal broke debug mode for RTL
RoanKattouw I tried to convince Krinkle to undo that but he disagreed
aharoni Oh, nice.
RoanKattouw This was broken in Berlin and discovered in Haifa
aharoni RoanKattouw, is this debug mode for RTL bug documented?
RoanKattouw aharoni: I don't think so, no
SPQRobin aharoni: I mentioned it on [[mw:Directionality support]]
RoanKattouw File a bug


Version: unspecified
Severity: normal

Details

Reference
bz30804

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 21 2014, 11:49 PM
bzimport set Reference to bz30804.
bzimport added a subscriber: Unknown Object (MLST).
Amire80 created this task.Sep 7 2011, 5:57 PM
brion added a comment.Sep 7 2011, 8:35 PM

See also bug 27025 -- assuming that bug hasn't actually been implemented without getting resolved as fixed, CSS is still being loaded via ResourceLoader in debug mode, and RTL transforms should work fine in theory.

Lack of RTL transforms when loading files directly was one of the reasons given for bug 27025 being a tricky thing to fix.

  • This bug has been marked as a duplicate of bug 27025 ***