Page MenuHomePhabricator

hdfs-tools: Stop using git-fat
Closed, ResolvedPublic

Description

What it says on the tin. We need to use git-lfs, or find a different approach.

Event Timeline

Change 887000 had a related patch set uploaded (by Chad; author: Chad):

[analytics/hdfs-tools/deploy@master] Drop vestiges of git-fat

https://gerrit.wikimedia.org/r/887000

Change #887000 merged by Btullis:

[analytics/hdfs-tools/deploy@master] Drop vestiges of git-fat

https://gerrit.wikimedia.org/r/887000

Upon investigation it was discovered that hdfs-tools no longer has any requirement for large file support, so we have merged this patch, which removes the git-fat configuration from the repository.

Change #1023393 had a related patch set uploaded (by Btullis; author: Btullis):

[analytics/hdfs-tools/deploy@master] Remove old hadoop coordinators from scap targets

https://gerrit.wikimedia.org/r/1023393

Change #1023393 merged by Btullis:

[analytics/hdfs-tools/deploy@master] Remove old hadoop coordinators from scap targets

https://gerrit.wikimedia.org/r/1023393

I did a successful deploy after having merged the patch to remove vestiges of git-fat intgreation, so I believe that we can close this ticket now.

btullis@deploy1002:/srv/deployment/analytics/hdfs-tools/deploy$ scap deploy
10:22:34 Started deploy [analytics/hdfs-tools/deploy@3618aab]
10:22:34 Deploying Rev: HEAD = 3618aab73c835f56a71f692c59b09dc1f973d094
10:22:34 Started deploy [analytics/hdfs-tools/deploy@3618aab]: (no justification provided)
10:22:34 
== DEFAULT ==
:* an-test-coord1001.eqiad.wmnet
:* an-launcher1002.eqiad.wmnet
:* stat1004.eqiad.wmnet
:* stat1006.eqiad.wmnet
:* stat1011.eqiad.wmnet
:* an-web1001.eqiad.wmnet
:* stat1007.eqiad.wmnet
:* an-coord1003.eqiad.wmnet
:* an-coord1004.eqiad.wmnet
:* clouddumps1001.wikimedia.org
:* stat1005.eqiad.wmnet
:* an-test-client1002.eqiad.wmnet
:* stat1009.eqiad.wmnet
:* stat1010.eqiad.wmnet
:* stat1008.eqiad.wmnet
10:22:42 analytics/hdfs-tools/deploy: fetch stage(s): 100% (in-flight: 0; ok: 15; fail: 0; left: 0) |
10:22:43 analytics/hdfs-tools/deploy: config_deploy stage(s): 100% (in-flight: 0; ok: 15; fail: 0; left: 0) |
10:22:44 analytics/hdfs-tools/deploy: promote stage(s): 100% (in-flight: 0; ok: 15; fail: 0; left: 0) |
10:22:44 default deploy successful
10:22:44 
== DEFAULT ==
:* an-test-coord1001.eqiad.wmnet
:* an-launcher1002.eqiad.wmnet
:* stat1004.eqiad.wmnet
:* stat1006.eqiad.wmnet
:* stat1011.eqiad.wmnet
:* an-web1001.eqiad.wmnet
:* stat1007.eqiad.wmnet
:* an-coord1003.eqiad.wmnet
:* an-coord1004.eqiad.wmnet
:* clouddumps1001.wikimedia.org
:* stat1005.eqiad.wmnet
:* an-test-client1002.eqiad.wmnet
:* stat1009.eqiad.wmnet
:* stat1010.eqiad.wmnet
:* stat1008.eqiad.wmnet
10:22:45 analytics/hdfs-tools/deploy: finalize stage(s): 100% (in-flight: 0; ok: 15; fail: 0; left: 0) |
10:22:45 default deploy successful
10:22:45 Finished deploy [analytics/hdfs-tools/deploy@3618aab]: (no justification provided) (duration: 00m 11s)
10:22:45 Finished deploy [analytics/hdfs-tools/deploy@3618aab] (duration: 00m 10s)