Page MenuHomePhabricator

Update Malayalam fonts packages
Closed, ResolvedPublic

Description

Currently Most of the Malayalam fonts in Wikimedia server are based on unicode 5.0. It cause display clutters in Server rendered pages. As far as now, only unicode 6.0 compatible font available for Wikimedia sites' server side is Anjali, which has a buggy Linux implementation. Please update Malayalam fonts to unicode 6.0 compatible. Unicode moved from 5.0 since April 2008, so I hope it is okay to use even hacked fonts, if there are no "upstream fonts" available.


Version: unspecified
Severity: enhancement

Details

Reference
bz31950
Related Gerrit Patches:

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 21 2014, 11:54 PM
bzimport set Reference to bz31950.
bzimport added a subscriber: Unknown Object (MLST).
Praveenp created this task.Oct 26 2011, 5:36 AM

I don't quite understand this bug. When are server-side fonts ever used to render wiki pages? Wiki pages are just HTML, rendered using client-side fonts, right?

Like in rendering svg, easy time line, webfonts etc.. :)

Reedy added a comment.Oct 27 2011, 3:52 AM

Are there debian packages for these fonts?

For no, there are no debian packages for hacked fonts (atleast to my knowledge :)). But all hacked fonts available in this archive https://github.com/junaidpv/Malayalam-Fonts/archives/master

(In reply to comment #2)

Like in rendering svg, easy time line, webfonts etc.. :)

Webfonts does not use the fonts in server. The extension contains the fonts in various webfont formats(WOFF, SVG, EOT,TTF)

svg bit looks fixed (See Bug 25140), so closing this since the fonts are apparently there.

No, it is not. SVG issues not fixed. Reopening.

(In reply to comment #7)

No, it is not. SVG issues not fixed. Reopening.

But this one will be fixed when that one is.

  • This bug has been marked as a duplicate of bug 25140 ***

Technicaly this is not a duplicate of bug 25140. After rsvg and rendering engine update, that bug completely depends on this bug (?). This bug may cause problems way outside svg to png rendering where pages contain server rendered elements (images in easytimeline, <math>(?), etc).

praveen:
Which Malayalam font is Unicode 6.0 compatible and has a working Linux implementation?

In my knowledge there is no font with full Unicode 6.0 compatibility available.

There is an official deb pkg for partially 5.1 compatible fonts (http://packages.debian.org/sid/fonts-smc) from upstream developers. But still those fonts have some errors and also I don't think they reached official Ubuntu repo. Please note that this package is happened to has a package rename (earlier the pkg name was something like ttf-indic-fonts-malayalam), I am not sure how this will affect the system. I hope Santhosh will explain.

But there are hacked fonts available (https://github.com/junaidpv/Malayalam-Fonts/downloads ; created by a fellow wikimedian [[:mw:User:Junaidpv]]) which are more up to date and error free. Among these fonts Rachana and Meera are best(gives most of the characters), and Raghu is the worst (Still has some old errors and has no newly defined code points)

(In reply to comment #12)

In my knowledge there is no font with full Unicode 6.0 compatibility available.
There is an official deb pkg for partially 5.1 compatible fonts
(http://packages.debian.org/sid/fonts-smc) from upstream developers.

They are partially unicode 6.0 compatible fonts. Glyphs used for archaic characters not added.

But still
those fonts have some errors

I am also a maintainer of those font and we are not aware of any errors that affects usage.

and also I don't think they reached official
Ubuntu repo.

I had filed a package update bug https://bugs.launchpad.net/ubuntu/+source/ttf-indic-fonts/+bug/958345 but no response so far.

Please note that this package is happened to has a package rename
(earlier the pkg name was something like ttf-indic-fonts-malayalam), I am not
sure how this will affect the system. I hope Santhosh will explain.

It won't affect anything.

I will try to contact some ubuntu developers to get this package update done soon.

Alternate solution is installing the fonts from upstream release( http://download.savannah.gnu.org/releases/smc/fonts/malayalam-fonts-5.0.1/ )

(In reply to comment #13)

They are partially unicode 6.0 compatible fonts. Glyphs used for archaic
characters not added.

Unicode 6.0 is a superset of Unicode 5.1 so I think you are technically correct, But I haven't seen any single character newly defined in 6.0 in those fonts.

I am also a maintainer of those font and we are not aware of any errors that
affects usage.

No! I quickly remember this one: Those fonts use Malayalam symbol 1/4 (0D73) for Malayalam Zero. Malayalam numbers are not popular, but it is still in usage. For example, Malayalam wikimedia projects using Malayalam numbers for marking footnotes.

I had filed a package update bug
https://bugs.launchpad.net/ubuntu/+source/ttf-indic-fonts/+bug/958345 but no
response so far.

May be because you people were totally defensive against updating fonts. :-)

https://bugs.launchpad.net/ubuntu/+source/ttf-indic-fonts/+bug/515607

Alternate solution is installing the fonts from upstream release(
http://download.savannah.gnu.org/releases/smc/fonts/malayalam-fonts-5.0.1/)

I recommend updating fonts from Junaid's github source than this source. Just because better fonts are better fonts.

This is surely not a site request, but what is it exactly? Is it for UniversalLanguageSelector/WebFonts to get different fonts?

(In reply to comment #15)

This is surely not a site request, but what is it exactly?

This is to update the fonts in the servers, used for any kind of server side rendering. Debian has all latest fonts, while Ubuntu is very slow in updating their font packages.

Thanks. So apart from waiting what can be done here? Modify Wikimedia's Ubuntu repo to include Debian's version of those packages?

(In reply to comment #17)

So apart from waiting what can be done here? Modify Wikimedia's
Ubuntu
repo to include Debian's version of those packages?

Debian version upstream package is also very old, and still has errors. If you are updating Wikimedia's repo, please update them using fonts from https://github.com/junaidpv/Malayalam-Fonts/downloads ([[comment 12]])

https://fedoraproject.org/wiki/Features/IndicUnicode6 implies that the "lohit-malayalam-fonts" package supports Malayalam in Unicode 6 since Fedora 17.

https://apps.fedoraproject.org/packages/lohit-malayalam-fonts lists package version 2.5.1-2.fc17 for Fedora 17.

http://packages.ubuntu.com/source/quantal/fonts-lohit-mlym lists
version 2.5.1-1 for Ubuntu 12.10. Note that Wikimedia servers run Ubuntu 12.04 which does not provide this package (hence a backport would be required), plus also that I'm not entirely sure that these two packages are really the same.

version in trusty is 2.5.3, appservers are upgraded to trusty because of hhvm now so we could do it if still needed

mw1018:~$ apt-cache policy fonts-lohit-mlym
fonts-lohit-mlym:
  Installed: (none)
  Candidate: 2.5.3-1
  Version table:
     2.5.3-1 0
        500 http://ubuntu.wikimedia.org/ubuntu/ trusty/universe amd64 Packages

@Praveenp : Would http://packages.ubuntu.com/trusty/fonts-lohit-mlym provide the required fonts? If so, we can add these to the app servers.

Sorry, I wish I could help, but I fed up fighting obduracy. I lost track of these things. :-(

fonts-lohit-mlym and fonts-smc has Malayalam fonts - all support latest unicode versions. Lohit fonts are less used compared to the fonts in fonts-smc package.

Disclosure: I maintain the fonts in fonts-smc package.

@Santosh : Thanks, I'll add the fonts-smc package, then.

MoritzMuehlenhoff set Security to None.

Our app servers are currently running trusty, but we're planning to migrate to jessie in the next months. jessie is already configured to use fonts-smc, but on trusty we currently use ttf-malayalam-fonts. fonts-smc is also available in trusty, but it replaces ttf-malayalam-fonts. We can certainly configure that for the remainings months we're using trusty if anyone can confirm that fonts-smc is a superset or improved version of ttf-malayalam-fonts.

ttf-malayalam-fonts is renamed to fonts-smc based on debian font package naming conventions introduced recently. All font packages in debian follows something like fonts-<foundry> naming convention.

+1 for fonts-smc.

I'm convinced, then :-) Will prepare a patch later

Change 287181 had a related patch set uploaded (by Muehlenhoff):
Add fonts-smc (Malayalam) to image/video scalers

https://gerrit.wikimedia.org/r/287181

Change 287181 merged by Muehlenhoff:
Add fonts-smc (Malayalam) to image/video scalers

https://gerrit.wikimedia.org/r/287181

MoritzMuehlenhoff closed this task as Resolved.May 19 2016, 7:11 AM

The patch has been merged and enabled on the image scalers.