Page MenuHomePhabricator

Navigation through revision history of pages with imported revisions is confusing
Closed, ResolvedPublic

Description

From IRC:

Go to https://pt.wikibooks.org/w/index.php?title=Predefini%C3%A7%C3%A3o:0&action=history&uselang=en
and click to see the diff of the most recent edit, which will be https://pt.wikibooks.org/w/index.php?diff=227984&oldid=216252&uselang=en

Do you know if it is normal not to have links to previous versions ?

Compare e.g. to https://pt.wikibooks.org/w/index.php?diff=216252&oldid=227983&uselang=en
(wich is the diff between the previous two edits in the history)

Is that the expected behaviour when a revision is imported from a file as was made by Reedy?

Besides,
https://pt.wikibooks.org/w/index.php?title=Predefinição:0&diff=next&oldid=216252&uselang=en
has no back link

and it is a revision from "10 March 2006" which the user gets when clicking on newer revision on the revision from "27 March 2011".

I think this navigation through the history should be consistent with what is shown on "action=history", in chronological order.


Version: unspecified
Severity: normal
See Also:

Details

Reference
bz31991

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 11:57 PM
bzimport set Reference to bz31991.
bzimport added a subscriber: Unknown Object (MLST).
He7d3r created this task.Oct 27 2011, 3:23 PM

I imagine it has been like this for a while, but I don't really know.

aaron added a comment.Oct 28 2011, 5:23 PM

The links assume rev_id is in chronological rev_timestamp order...which it isn't. They should be using rev_timestamp queries.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 18 2015, 6:24 AM
Aklapper lowered the priority of this task from Normal to Low.Sat, Aug 10, 4:17 PM
Aklapper updated the task description. (Show Details)
Aklapper removed a subscriber: wikibugs-l-list.
Aklapper closed this task as Resolved.Mon, Aug 12, 11:18 AM

Go to https://pt.wikibooks.org/w/index.php?title=Predefini%C3%A7%C3%A3o:0&action=history&uselang=en
and click to see the diff of the most recent edit, which will be https://pt.wikibooks.org/w/index.php?diff=227984&oldid=216252&uselang=en

Do you know if it is normal not to have links to previous versions ?

There is a link to the previous version now.

Besides,
https://pt.wikibooks.org/w/index.php?title=Predefinição:0&diff=next&oldid=216252&uselang=en
has no back link
and it is a revision from "10 March 2006" which the user gets when clicking on newer revision on the revision from "27 March 2011".

It has a backlink and the date seems to be correct now.

@He7d3r: I'm going to close this task as resolved, but please reopen if I misunderstood something or if you see something different. Thanks a lot!